Push of some apps works on work profile but not on private profile

Hi everyone,

I have a school app that shoud push as soon as the teacher write me a message. But I don’t revieve the push. In my opinion all options are set to recieve pushes. On my wifes phone with the exactly same setup is working fine. Today I tried to copy this app from my private profile to my work profile via shelter. And on my work profile I get the push messages.

On my push setup there is indeed a diference, the menue miscellaneous is not ahowing on my private profile. On my wifes fone and my work profile this option is shown. And i would say its because of this missing menue that I don’t recieve pushes from this app on my private profile.

So app version, operating system are identical to my personal profile.

I asume that somthing in my settings are difderent bit I can’t figure out what exactly. I tried to remove the app an reinstall ist, clear cash…nothing helps.

I also have the imprestion that some other app are also not pushing who should do .

Like proton did but not anymore.
Some other apps do push properly…

My phone operating is eOS ve.1.17

Look at the screenshot one is my work profile and the other my private profile push seting of this specific app.


Thanks for the help.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

No idea?

I try to explain it again.

I don’t recieve push notifications of apps that should work or used to work.
Norton Mail is no pushing new incoming mails, klapp is also not pushing. I installed klapp in my work profile with shelter and now i get push notifications. I will try to install proton mail into my work app and see if i get pushes.

Basicly i don’t want to install this apps into my work profile because there are no sensitiv datas there and it should stay like that.

So I’m wondering why i get push for the same app in my work profile but not in my main profile. In my opinion all push settings are correct.

Thanks

Found a solution here

https://forum.fairphone.com/t/issues-with-push-notifications-on-the-lineageos-microg-version/69902