Random "Select SIM card" notification on Fairphone 2

fairphone

#1

Starting the phone shows right when the home screen comes available random the message “Select SIM card” either empty or (for the first time since image 0.5-201902233562) with named SIM cards and numbers.

Touching the home screen outside the message window closes the message. I never selected a card the times it shows named SIM cards since I have no idea what that message means.

This happens since a couple of months, I just couldn’t find the time to report.

Happens using two SIM cards (I never tried with just one), system version: 0.5-201902233562 with Fairphone 2.

Can someone help?

Thanks!


#2

Happens with only one SIM card too (your first screenshot), but only after reboot. I never worried about it, so never reported it. Happened in /e/ v-0.1, in Unofficial builds v-0.2, and now in eel-0.5 on FP2.


#3

I guess this would be appearing on specific devices. I just rebooted my MiA1 and did not see this pop up to select sim. Would make sense if it appears during the initial setup as user may be asked ( in case of dual sim) which sim he/she wanted to use for mobile data and as primary sim on the phone. That being set it should not come up every time the phone reboots. Please raise it as an issue in Gitlab if not already done.


#4

I added also the user experience from @pjmbraet


#5

This message does not appear on my FP2 (with 2 SIM cards), also not after a reboot. It might have appeared during initial setup (I don’t remember that) but it has never appeared since then.
The phone is running 0.5-201902233562.
in SIM settings one SIM is selected for mobile data and SMS and for calls “ask every time” (so obviously a message comes up when starting calls, but then it directly asks for which SIM to use for this call…).


#6

My setup has ever been:

SIM 1 for mobile data
SIM 2 for SMS messages
Calls ask every time

That is slightly different than yours @ff2u and might be a hint for the developers…


#7

As default SIM for SMS is arbitrary for me I’ve now changed it so our configuration is the same here. I’ll monitor if the message also appears for me now. On a first reboot it didn’t. But as you said it might just appear from time to time…


#8

You’re not using default Bliss Launcher, but a custom one? Could this possibly be related to the said messages (as message appears on phone/launcher start)?


#9

I’m using Lawnchair.

I’d say it’s not related since I’m using Lawnchair from the very beginning using FP2 + /e/ and the messages appeared sometime (I don’t remember exactly) in /e/ v-0.1 but definitely not from the beginning.
Maybe @pjmbraet can tell us what launcher he uses since he experiences the same…


#10

Blisslauncher, default in /e/.


#11

@pjmbraet: thanks for reporting
@vic.fontaine: you’re right, it doesn’t seem to be the launcher. But probably also not default settings for sim cards. I’ve still not experienced the message although our settings are now equal.
Maybe some installed app?


#12

Just now, i got the message (screenshot 2) with the recent image 0.5-201903013788 again

My custom apps are:

  • Wire
  • Barcode Scanner
  • KeePass DX

Everything else is /e/ default.


#13

I can now confirm that it seems to be a general PF2 problem as it has lately happened to me too once. I saw the second version of the message: the one with the named SIM cards and numbers.
EDIT: one more thing: it can be coincidence, but wanted to mention that the message appeared when SIMs were in roaming mode.


#14

I guess that was coincidental since I haven’t used neither national nor international roaming. Both SIM cards use the Telekom network.