Realy bad battery life since 1.15

since I’ve updated to 1.15 version about 2 weeks ago. My battery life reduced dramaticly. Last week, I’ve pute my phone in battery save mode, switched of mible data connection and did not touch the phone for about 10h, it was 100% full. Wifi and Bt was also off.
After 10h I had only 35% left (screenshot).

Before 1.15, if I witched mobile data off, it last over 24h easely.

This is realy anoying, battery life is always a big deal with fairphone and eOS.

I installed BBS (but I don’t understand the stats there) and also have battery bot pro installed for over a year now.basicly every 3 minutes I loos 1% battery live. Wich is big in my opinion.

Is there a known issue in version 1.15 regarding battery life?

How can I save my battery best?
I also installed SaverTuner but this dos not help at all.

My setup is, eos 1.15s stable
Fairphone 4
I do sync with my nextcloud selfhosted server
I don’t over use my phone, so I would say normal use. I don’t have SoMe apps installed. Normal news reading, writing etc…

The second screenshlt is from today. Wifi is now off because I’m out of home. And the mobile data are now on because I nedd it.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have similar configuration ad use: FP4, eOS 1.15 stable, my own NC, read news, not often write…
I turned network from 5G to 4G and save hours of battery.
You can try, if speed is not so important to you.

Did someone of you clear the caches? After an OS update it’s always a good idea to clear the cache of each installed app. There are specialized apps doing this automated for all (Cache Cleaner from F-Droid). In many cases a not cleared cache is the reason for abnormal energy consumption of an app.

Sending data can also be a reason. I switched off the mobile network data connection while wifi is on. This mobile network data connection is on by default even when the device runs on wifi which costs ongoing keep alive messages to the next mobile antenna. There’s an option in the developer settings for that.


Thanks for thr feedback. I will try 4g but it used to be good before 1.15s, even with 5g.

I do sometime togel the data connection to off when I’m in a secure wifi.

Is there any possibilities, to switch off data connection while the screen is off? An as soon as it is on it switchs back.

I know, if so i will not recieve any push notifications. But I have almost no push nofifications on so it would be nice. Calls should work.

Cache cleaner shows mee that there is no cache, so I don’t know if I have to wait or maybe to go in each app and delete it manualy. Thanks anyway for this tipp. I never heard of it until now.

No, because this would break any serious communication over data connections (messengers, mail, …). And even if you manage this it would cause a lot of delays because the several connections to the servers have then to be reestablished and the servers must be requested.

Almost every app (and system apps too) has a cache. When you update the OS the cache remains but is now not actual anymore. That’s why you should clear all caches. You can do this by hand but it will take you a lot of time. CacheCleaner takes 2 minutes for that, and you can be sure that it affects indeed all.

So it looks pretty good at the moment.
I did clean the cache of all apps. I switched back to 4g and with this option I also deactivated the automatic provider search (wich did no work in 5g. In 5g I could only automaticly search the provider).

And now I have a battery life of over 1 day and 8h.

Thanks for the help.

1 Like

I have similar experience.
Battery life was never good, but since 1.15 it was really bad (<20h with really less use [2min www, 2 messages, no call, no music, no games. just on and ready)
I clear caches now and I will see.

But I want to ask for experience for “normal One-Charge-battery-life” to compare.
With V1.14:
If I load my FP4 to 100%. Lay it on a table on midnight. And no use for the next 8 hours (wifi off, 4G normal signal strength). And I receive no messages. It will be most time <80% at the next morning.

20% for no use/just “ready” for receive in 8 hours. I always think it is too much. Much too much.

So its only max. 1,5 days working with one charge. For me it feels like the “doze mode” had a strong power consumption.
Can somebody compare his/her experience? Life time with just ready?

Thank You!

I’m by far an expert, but what I noticed is that the first 20% of the battery drops quite fast. But from 80% to 20% takes quite a long time to drop.

Since I switched to 4g, cleaned the cash and set the screen brightness to fis and not automatic, my battery life incresed massively.

Not for “no use”. In this time your device keeps the network connection alive by sending keep alive messages on and on and does background tasks like requesting mail servers and messengers, perhaps also the cloud. Even when nothing at all happens this costs energy, especially on a mobile network. That’s why I switch the network connections completely off (using the flight mode) over night and lose less than 10%.

Yes of course there are background tasks.
KeepAlive for mobile, …
For me theoretically not more: Messages are using push, mail only manual receive.
Of course is flight mode less using energy. But if its offline: Why not turn off?
thats more less than 10%…

@ Snowest:
That means “incresed massively” ?
How many % for 8h with nothing or less use?

Turning off is the best solution. But it has the disadvantage of starting the device completely in the morning, this means booting, including typing the PIN. This all takes time.

1 Like

Just an addition:
I remember in beginning of my FP4 with /e/ I survive 2-3 days with normal use.
I don’t know what happens. I always thought: little bug, will disappear with an update.
And now I am used to!
Or my battery is broken…

I followed the link in this:

I have a 1st analyse. But not really new information. Have to compare a few days.
But I can see only little difference between wifi on or off.

This topic was automatically closed after 60 days. New replies are no longer allowed.