Recovery : is usb stick / sdcard access supported?

I’m greatly interested in /e/os after discovering the microg project, I’ve used TWRP for ages (on a SM-N910F, trlte) and lately I installed a official lineageOS on a d2s (SM-975F/DS) because I needed a phone with double sim.
but the lineageOS recovery sucks a lot, in particular having access to USBOTG drive/sdcard did saved me several times in the past, when I accidentally broke the phone on the go, without computer access and needed to reflash… so for me a recovery that don’t have a usb drive support or sdcard access is :fu: (so I installed TWRP, anyway the lineageOS recovery sideload never worked with any gapps package tried (litegapps, nikegapps…) so to install gapps the only way I found was TWRP )

but… after trying OTA update of lineageOS, that didn’t gone well

  • the OTA did broke the gapps, with all app relying on google services unusable, a popup displayed saying the service is crashed every second,
  • so I tried a re-install of gapps, that created the endlessbootlloop (that is a lineage os bug when you install the gapps after the first boot…)
  • hopefully, dirty flashing the lineageos with gapps as if it was a update did solved the issue

(I reported a bug to lineage, but their support is awfull, they even replied me that since nobody reported the bug before, the bug don’t exist… :thinking: they said the issue was because I installed unsupported gapps, but don’t said what gapps is supported :thinking: and well, I was close to loosing all my phone data because lineage only support install of gapps before first boot, but instead of working on the issue (allowing to install gapps after first boot) they closed the issue saying they won’t investigate…)

so I searched another rom and found about /e/ and microg… and at least there seems to be a community and forums to find help, not :face_with_symbols_over_mouth: dev that don’t care about user support and that don’t find that a bug where the user might loose all it’s data is interesting to investigate… I hope that /e/ support is more user friendly… and more user concerned… will never advise anyone to install lineage now…

I saw that crDroid seems to have a recovery with flash drive / sdcard support, what about /e/recovery ? /e/ seems to have more privacy features…

(and some other question, but more related to d2s : does device encryption works?)

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

The /e/ recovery does support external storage.
On my Teracube w/1.10, under ‘Apply update’ it shows ‘Choose from T2E_SD’ and ‘Choose from usbotg’.
On the Essential PH-1 w/1.8 it shows ‘Choose from usb’.

So yeah, you should be good.

1 Like

From my Samsung Galaxy s4 :


But you still can use TWRP

This topic was automatically closed after 90 days. New replies are no longer allowed.