Recovery mode inaccessible - bootloop - no /e/ logo

Thank you in advance to anyone reading this! I’ve been using /e/OS since 2019 without a hiccup, but after installing the latest build for my Pixel XL on April 18th the phone started randomly rebooting out of the OS. It’s now at the point where it hangs on the unlocked Google screen and enters a bootloop.

I was able to enter recovery mode and do an adb sildeload of the latest build. I did this because I could not turn on Developer Mode due to the bootloop. This got me back into the /e/OS once. I was able to enable USB Debugging and USB file transfer which I immediately used to backup some photos. After the file transfer to my PC was completed the OS randomly rebooted again and now I can’t even get into recovery mode.

I read that updating TWRP can fix this issue (I’m using something from 2019). When recovery mode worked it was a black screen with a big LineageOS logo and only 4 icons to click (reboot, advanced, restore & backup I think). However, I can’t get to recovery mode to install TWRP. I’ve tried with the USB cable connected to the PC, I’ve tried without the cable, I’ve tried plugging in the cable at various points. No luck.

From the bootloader screen (the one with the Android robot on its back and the belly door open) I tried running the following:
C:\adb>fastboot flash recovery twrp.img
Sending ‘recovery’ (27545 KB) OKAY [ 0.689s]
Writing ‘recovery’ (bootloader) Flashing active slot “_a”
FAILED (remote: ‘partition [recovery] doesn’t exist’)
fastboot: error: Command failed

C:\adb>adb reboot bootloader
error: no devices/emulators found

The bootloader is unlocked and I still get the warning screen about not being able to check the device for corruption right before the unlocked Google screen appears.

Again, thank you to anyone who can give me some guidance. I’m using an old iPhone and miss my /e/OS dearly! ;p

Hi Alex5, The random reboots are a strange problem and and I’m wondering whether the battery might be starting to go because this can cause some odd behaviours on a device. Also strange that you cannot get into recovery for reasons I will try to explain.

I don’t have this device but I can see that it has A/B partitions layout, aka a/b device, twin slot device etc. You can research this if you are unfamiliar with it.

The recovery resides in the boot.img and to flash a recovery onto this device you have to flash ‘boot’ which requires a different command: fastboot flash boot recovery.img Please see the marlin installation instructions for all the steps. I don’t think you can flash over boot with a new recovery a nd expect the phone to reboot from there; you would have to do an install (sideload the os) in order to continue.

I’m not sure what your understanding of a/b devices is but basically what has been happening every time you updated since 2019 the new os that comes as ota is a complete os and it would have it’s own recovery in the boot img as part of it. It downloads to your device and installs into the inactive slot where you will reboot into.

This would have most likely been the recovery that came with the last update and because you were able to sideload latest build (version 1.0, I presume?) and boot into it, the device has changed slots and would have it’s own recovery (which would be the same as the one bundled with the os on the downloads page)

I don’t know why you can’t boot the recovery normally now. Simplest thing might be to try installing again using the recovery and os versions from the /e/ downloads page and following the instructions for flashing the recovery etc.

Hi chrisrg,

Thank you so much for the in-depth reply! I will do some research on the A/B partitions so I understand this better. The battery is old, but I’m not convinced it’s the culprit just yet due to the issue manifesting immediately after the last update. Also, it still happens while plugged into a power source.

Thanks again!

On some devices it’s possible to boot twrp on the phone in fastboot from pc (without anything being flashed over on the phone) using the command fastboot boot twrp.img

Actually, I think this is the first step of physically installing twrp. I’ve done this a couple of times before on a sony xperia xa2 which is a similar a/b device. It’s a procedure to be carried out after os is installed and since you have e os on both slots I wondered whether it might be worth a shot.

Here are the twrp installation instructions for xa2.

OK, so I figured out my initial confusion on the fastboot command. I was using the marlin instructions here Marlin Upgrade (step 7) instead of your links.

That said, I ran the following two commands as suggested:
C:\adb>fastboot boot twrp.img
Sending ‘boot.img’ (27545 KB) OKAY [ 0.667s]
Booting OKAY [ 0.990s]
Finished. Total time: 1.711s

C:\adb>fastboot flash boot twrp.img
Sending ‘boot_a’ (27545 KB) OKAY [ 0.698s]
Writing ‘boot_a’ OKAY [ 0.773s]
Finished. Total time: 2.361s

Sadly both resulted in the same bootloop :stuck_out_tongue_closed_eyes:

My bootloader shows the following info:
Boot-slot: a
Device is UNLOCKED

So at least we know fastboot was sending the img to boot-slot a which is good.

I’ll need to read up more a/b devices. And yes, it was version 1.0 that I sideloaded.

Thanks again for the links and suggestions! Everything is worth trying at this point. :slight_smile:

Presumably you flashed boot with the latest twrp from their download page: twrp-3.6.1_9-0-marlin.img?
As you say, good you know it at least got sent!
twrp won’t boot manually with device unplugged from pc? Are you using the latest fastboot version?

If that’s all good and makes no difference you could try booting the other slot, which is where you were at the top of this thread, ie you could at least boot the recovery then. Don’t get your hopes up though.

Steps to do that, in fastboot: fastboot --set-active=b followed by fastboot reboot

Are you still hoping to get to your data, or don’t mind losing it since you backed some stuff up?

I’ve read that too much data on the phone can cause
random restart problems. If you suspect this may be possible fastboot -w will erase userdata.

Yet another fastboot command to bring up some info to look at: fastboot getvar all

If none of that works consider flashing stock google android 10 (last release). It’s easy on a pixel, all done in fastboot. Plus it flashes both slots (if it’s similar to pixel 5). You could hopefully boot it up and run it for a while to check if the previous problem is there still.

Thank you SOOO much for the ongoing suggestions! Yes, using TWRP 3.6.1_9 and latest adb/fastboot package for this. I will try accessing TWRP (recovery mode) with the device unplugged before moving on to the additional fastboot commands you have suggested.

Do you think the second newest release of TWRP is worth giving a shot? Likewise with trying to downgrade /e/OS to the version prior to upgrading (assuming I get that far)?

Storage was not maxed out. Probably close to 75%. I’m definitely aiming to get access one more time and save 3 important draft emails before I throw in the towel.

Thank you again for being so generous with your time!

(Rather late at night for me) … I did not notice before that a change of Android version might be involved. You say you are using latest Platform tools and latest TWRP – that rules those out. Good.

So, now, slot trouble seemed to me the most likely problem. – but not being on a matching Android version before you start, trumps them all !

@aibd thanks for the feedback! I believe I’m good on that front as I’m assuming the April 18th OTA update matches the version I sideloaded here. I’m not 100% certain since I can’t see the release dates of the prior images on the ecloud site :confused: I wonder if there’s an archive of old releases to reference just to be certain?

@chrisrg I re-ran the previous flashboot commands and unplugged the USB after execution to see if that would help. No dice. I also set boot-slot b:
C:\adb>fastboot --set-active=b
Setting current slot to ‘b’ OKAY [ 0.417s]
Finished. Total time: 0.465s

C:\adb>fastboot reboot
Rebooting OKAY [ 0.010s]
Finished. Total time: 0.015s

Then I re-ran both fastboot commands again. No dice. :unamused:
getvar produced a big list of settings, but I wasn’t sure what to look for specifically.
I may need to consider a stock Android flash as you suggested. Thanks again!

Is it on slot b now and did you try to boot recovery in slot b? The recovery there should be the one you managed to boot at the beginning of this thread.
ie: power off device, manual boot recovery with button press combo

Not sure which one’s you mean.

@chrisrg If I use fastboot update, does this accomplish the same thing as the sideload feature in recovery mode? Would this command wipe out my user data? I’m just aiming to get back into the OS one last time to save a couple things before starting from scratch.

I don’t know, sorry.
What about booting recovery only, on slot b now?

I think it requires a special fastboot zip for that feature…

My mistake, I saw the word downgrade and jumped to conclusions! You see the release date within a ROM name like

2022 05. 27 188878

/e/ do not generally keep any older ROMs.

I was searching the forum for a b slot guidance.

We had some new users of Fairphone 4 got tripped up with slots, but I could not find the good text I saw. @chrisrg is being quite specific in this matter – following up the getvar output with a study session might help inform you.

You have confirmed that your Pixel was on pure stock manufacturer Android. 10 (not any other custom ROM) before you started?

adb sideload and fastboot do different jobs, please don’t use different commands on a whim!

@chrisrg Yes sir! On slot b I re-ran fastboot boot twrp.img & fastboot flash boot twrp.img. Same result as in slot a (i.e. Google screen comes up and then enters the bootloop again).

@aibd That’s right, this was a stock Android phone before I switched to /e/OS in 2019. OTA updates ever since.

It seems like I’m locked out of the adb commands altogether. I can only get the phone to the bootloader and adb doesn’t work from there. Maybe I need to re-flash as @chrisrg previously suggested.

Thanks to both of you for helping eliminate various options!

I could not find the good text I saw.

It was this FP3 latest update corrupt, doesnt work - #8 by AnotherElk.

Great thread @aibd ! I see AnotherElk references the same commands that @chrisrg suggested. I note that the final post in the thread says to try booting >3 times once the slot is switched. I only tried twice in slot b last night. I will go back and re-try slot b a few more times just in case. I’ll re-read the FP3 thread a couple more times to make sure I understand all the nuances of the A/B slots :face_with_monocle:

Once you learn to use fastboot to diagnose the slot issue, you might have to assert that the build is unusable and Report an issue – and ask for a re-print of v0.23 in due course, perhaps?

Though last resort, this would be better than risking harm to your device.

You always have the fallback of the manufacture’s ROM – or is this problematic?