Redmi note 7 - can't install recovery

Hello,
I’m trying to follow this tutorial: Install /e/OS on a Xiaomi Redmi Note 7 - “lavender” in order to install /e/ os on my Redmi Note 7 but I’m stuck on the step Installing a custom recovery using fastboot.
I could unlock the device, I executed the fastboot command which seemed successfull:

$ fastboot flash recovery ./recovery-e-2.1-r-20240606407290-dev-lavender.img 
< waiting for any device >
Sending 'recovery' (65536 KB)                      OKAY [  2.346s]
Writing 'recovery'                                 OKAY [  0.446s]
Finished. Total time: 2.796s

Then I power off the device and try to get into the recovery with vol up + power, but:

  • I see no MI logo as documented, only a redmi, or MIUI one
  • The best I could obtain was a kind of recovery, but that doesn’t matches the menu described, for example it has no factory reset menu entry, only Reboot, Wipe Data and Connect with MIAssistant

Am I doing something wrong? The smartphone is up to date, could it be that the SW version present is not supported?

You have ended up in the Android Recocery instead of /e/Recovery.

  1. Now reboot into recovery to verify the installation:
  • With the device powered off
  • hold Volume Up + Power.Keep holding both buttons until the “MI” logo appears on the screen, then release.

The decisive factor here is pressing the key combination at lightning speed after switching off the device or after the screen has gone black.

Hello, thank you @Xxpsilon for your answer.
I think I finally managed to install successfully /e/ :crossed_fingers:, but it took me multiple attempts…
What (seems to have) worked for me was:

Maintain power + vol down until fastboot shows up (it worked from any device state if held long enough).
Flash ./recovery-e-1.21-r-20240323388943-dev-lavender.img which is not the latest one.
From fastboot, hold power + vol up until, the device will reboot at some point, continue pressing for some more time, I think approx 7s. If not long enough the device boots normally, if pressed too long, the device would reboot. There was no helpful logo change here.

And then I applied via adb, the latest /e/ software package, e-2.1-r-20240606407290-dev-lavender.zip ATTOW.
The device has been trying to boot for several minutes now, I don’t know if that’s normal. I’ll wait a little bit more and I’ll post the end result here.

When using the current latest recovery (recovery-e-2.1-r-20240606407290-dev-lavender.img), I never managed to enter it.

Side question, is it an issue that the recovery and /e/ version I’m using are not the same?

Finally, I succeeded to install /e/, now I’m playing with it!
I still have the “old” recovery with the “new” /e/ version, but it seems to work…

As long as the older version e-Recovery performs the installation of a newer /e/ROM version without errors, there is no problem.

It is recommended to activate the automatic installation of the newer e-Recovery during the initial installation or subsequently in the updater settings so that it is updated during the next OTA update.

I have already experienced several times that this does not always work reliably for every device, which means that the e-Recovery was not always updated, although it was desired and specified.

I couldn’t find a way to enable automatic update of the Recovery.
I tested the last 2 versions of the recovery, 2.1 and 2.0, but none worked. So I guess I’ll stick to version 1.2 then :slight_smile:
My main issues were the keyboard that doesn’t provide swipe (but I installed florisboard) and my bank application doesn’t work for the validation of critical operations, but I suspect that has to do with the unlocked status of the phone’s SW…