[Resolved] Problem flashing Oneplus 3T

Hello, so I’m a new user and failing to flash to an OP3T. It’s unlocked etc, I have TWRP and have /e/ on the sdcard. My problem is regardless of which sideload method I use, it fails. I moved this post as I’ve just discovered where it should go! So here’s the deets because there’s a wee devil in them:

  • I just bought the phone, there’s no data. I’m changing horses from my BlackBerry 10 :slight_smile:
  • I have e-0.12-q* and e-0.13-q* zips plus associated recovery imgs. Md5 sums are fine.
  • It appears I can only download ‘q’ images, which confuses me per other things I’ve read.
  • The op3t had Oxygen 9. If there was a point release to that, I didn’t notice.
  • Originally, I sideloaded e-0.13 across adb and it transferred 100% but failed on the phone side. It looks to me like this is the root of the problem. I think it’s a firmware issue, amongst many other apocalyptic scenarios. I might have jumped the gun. In my defence, I’ve years of experience being a moron.
  • I’ve reformatted etc including system, but nothing sideloads beyond a dozen percent or so, with an error 7, E1001 (line 13 in the zip’s install script)
  • I’ve tried the 12 and 13 versions. I replaced the fastboot image to 12 as well, fwiw.
  • I downgraded TWRP to per some advice I’d read.

I can’t get beyond this low percent problem. I suspect I might have to install an older version of /e/ and then upgrade, but I don’t know where the repository is for that, unless I have to self-build? I’m running an Arch Linux derivative etc. for my PC.

Can anyone please advise what my next steps should be? I’d be very grateful, thank you.

EDIT: As a way of an update, I checked the zip’s md5 on the phone (post adb transfer) and it seems my cable is garbage. Astonished adb didn’t complain, I’m a bit sceptical. Anyway, it makes sense because transfers keep failing for various reasons. So Ludix is correct in his suggestion. I’m not in the USB-C world yet, so will have to get a decent cable and an OTG drive tomorrow. I’ll post the outcome then.

EDIT: Resolved, see post below.

As a workaround, you could flash via thumb drive connected to your device.

Copy the img file to a thumb drive, navigate to the file and flash it directly via TWRP. Micro SD Card might work as well.

I made it work this way on my Galaxy Tab.

Edit: I followed these steps back then: [Device Roadmap] Android 9 (Pie) & 10 (Q) : Test builds to support new devices

1 Like

That’s an interesting approach I hadn’t considered, thank you. I think the problem though isn’t reading the file, it’s that I’ve got the wrong file entirely :wink: I just don’t know where to get the right one, if I’m correct.

Just FYI
I had twrp-3.3.1-1-oneplus3.img on my 3T for about a year until I sold it recently.
/e/ recovery 0.11 installed alongside eOS 0.11-q fine.

Only problem I had was trying to install e recovery 0.12, tried a couple of times, no joy, so re-installed twrp, no probs.

So this is now resolved! I am a very happy boy. The problem… was the cable and adb not complaining the time the data transferred in mangled fashion. Small transfers seemed ok (recovery image) but the larger ones failed. Props to Ludix.

So here are the gems I needed to know as a noob Android user who hits that dangerous threshold of having ‘a little bit of knowledge’:

  1. When installing /e/ on a stock phone, it doesn’t matter if the correct /e/ is based on a later Android version. There aren’t firmware issues to worry about.

  2. Ensure you have good cables. If sideloading fails, then it might be a cable issue. If transfers succeed (per ‘adb push /e/.zip /sdcard’) and the installation still fails then it might still be a cable issue. In the TWRP terminal you can test this by doing the following:

    cd /sdcard
    md5sum /e/.zip

(where /e/.zip is the name of the file, e.g.: e-0.13-q-2020120789006-dev-oneplus3.zip)

The resulting checksum must match the sum supplied in the original /e/ download repo. You can checksum the zip on your pc prior to transferring (which you should have done after downloading anyway) to get the string.

1 Like

Do you know if having recovery 0.12 alongside a 0.13 install is a bad idea, or even ‘a thing’ to worry about… uhm someone ‘close to me’ might currently be running their phone in such a configuration…

No, I don’t know. I would guess not though. When getting ota updates it wouldn’t update recovery as well would it?

This is just guessing, but it may just be that newer recovery versions may introduce more features. Wonder if you can see changelogs for that sort of thing?

Congratulations on getting your phone sorted though. I found the OP3T to be a great device, and just so easy to flash images to! Just bad luck with your cables. BTW I returned the phone to stock before selling and that was super easy too.

Cheers. Yeah I don’t think it ought to be a problem either and that makes sense with the OTA. My temptation is to over-correlate the recovery rolling release with the main install.

Once the cable was replaced it flashed like a charm. I was holding my breath. I’m really looking forwards to using this phone; I had to do something with my old BB10 because of port wear but my need for decent 1080p60fps video capture meant ‘new phone’. Presumably it’ll give me better bandwidth once tethered to my router as the BB is quite limited. I’d always read good things about the early OnePlus phones and found them ‘desirable’ so now I’m livin’ the dream :crazy_face: