Revolut - top up

Redmi note 9 pro
eOS v2.0

I can not make to-up funds. I tried to add the card again and I get this message inside the app:

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

Revolut processes that with ‘stripe’ I think, I use TC (TrackerControl) besides AP (Advanced Privacy), after I open that one it worked for me.

I also use TrackerControl.


Please, wtf is stripe?

Here the ‘tracker’ is called stripe

Sorry for the late replay!

I don’t have that tracker

maybe some other ‘tracker’ gets triggered before. Check immediatley when trying. You can guess it from seeing the seconds

I have just received notification from revolut:" Revolut won’t run unless you update google play services."
I have redmi note 9s on e os 2.0.
This was received when I was updating bank card for top up. But for now it works, card is added and top up made. Still warning makes me uncomfortable to rely on Revolut from now on.
This seems very similar to your case if not the same.

Mine is prepaid mastercard.

I think that with VISA is OK.

I updated card as bank was switching from visa to mastercard. I have got message on mastercard but it still works.