Rollback FP4 to stock Android stuck at file transfer

I gave a try to /e/OS on my new FP4 and used the easy installer. Everything went smoothly and I could try the OS for a couple of days.
Unfortunately me employer is relying heavily on the GSuite and microG doesn’t solve all the issues with the google apps yet, so I need to revert to the stock Android.

When in fast boot mode, the flashing script starts but doesn’t copy the files. Here is the complete output:

*** Fairphone 4 flashing script ***

INFO: The procedure will start soon. Please wait...
INFO: The package type is "user-factory"
INFO: The build number is "FP4G"
INFO: You are using macOS.

INFO: Validating the integrity of the package.
      This might take a while. Please wait...
INFO: Validation complete.
WARNING: Flashing this image wipes all user data and settings on the phone.
         It will also remove the Google factory reset protection.
         Are you sure you want to continue?
         Type "Yes" (case sensitive) and press enter to continue: Yes
INFO: Looking for connected device(s)...
INFO: One Fairphone 4 in fastboot mode found (serial number: d******9).

I used the same laptop and cable as when I flashed the /e/OS ROM in the first place and tried a different cable (USB-A=>C and USB-C=>C) and a different laptop (macOS and Win 11).

The phone is “factory reset” and reboots fine but still under /e/OS.
Can someone tell me why the Android image files are not transferred to the device?

To revert to stock, you will need to refer this Fairphone guide
The Flashing script will install /e/OS. This is mentioned on the FP4 device info page

Hi Manoj, thanks for the prompt reply.
I forgot to mention, but yes I followed that guide on the Fairphone page you mention (with the image FP4-FP4G).
Everything is fine until I run the flash_fp4_factory.command script that provides the output copied my previous post.
Any clue about what I could check?

The bootloader is unlocked?

Yes, the bootloader is unlocked: DEVICE STATE - unlocked (on fastboot screen)

1 Like

So, I figured what was causing the issue: the flashing script provided by Fairphone calls the fastboot tool which is in another folder, so I just adapted the path in the script and it worked.
Thank you for the support!

Hi, I am experiencing the same problem. I read through the flash_fp4_factory.command,but I notice the fastboot.exe file is located where the script attempt to call it. Can you tell what you did to modify the path? Thanks.

Hi @Rmizell, sorry for the late reply, I modified line 243 of the script to include the relative path:

  DEVICE_INFO_OUTPUT=$(../platform-tools/fastboot oem device-info 2>&1)

I’m using macOS but it should be similar for Win…
If the fastboot tool in the same folder, maybe you can also try adding ./ before, sometimes that works for me…