Rosetta Stone app not working


I’m opening this because I can’t get the Rosetta Stone app to start, and this since the beginning.
I can’t get past the splash screen, it just flashes white indefinitely and the application never starts properly.

I’m using the FP3 along with /e/. I think you can reproduce by installing the application and try for yourself as it doesn’t even ask me to authenticate.

I’m crossing my fingers at every /e/ or Rosetta Stone update but it’s still flashing on the splash screen.

If anybody knows how to bypass this that would be awesome. Thanks


Probably, R.S. app’s looking for “authentiques” gg plaie sevices… Perhaps you can try the workaround I’d tested, but not sure it will work. For other apps (Banque Populaire), it didn’t ever…

In fact, it’s just a poor ‘handiwork’. Good luck.

So I just tried and I gotta admit that I believed it was working at first.

So I installed Shelter, tried to add a Google account but it couldn’t reach google’s server. So I launched sh-Aurora but same, can’t login anonymously or not. So I launched sh-Apps and could reach the store. I installed Rosetta Stone which became sheltered. Then I launched it and it wasn’t flashing, but then the logo animation at startup started glitching and looping, and I knew it won’t start loading :confused:

Thanks a lot for this idea anyway, I hadn’t thought about it, but it seems it did not work as a proper workaround :frowning:


For french SNCF’s app., it only worked on e-0.9-n-unofficial-surnia by adding a gg account in main profile (without Shelter).

All tests I’d made then from Shelter aborted (without gg account in ‘main’).

In other way, I’m using the french SNCF’s app, and never had any problem with it, worked from scratch, I think I just installed it from Aurora and that was it.

As for Rosetta Stone well, I guess Imma just have to stop using it, the web version is not practical enough for me. /e/ is also about making compromises x)

Yes, for sure !!!..