S10+ (beyond2lte) unable to join T-Mobile GSM network

I’ve got a S10+ (SM-975F) and before installing /e/ on it, I put my sim in and tested calling and texting functionalities. Now, after installing /e/ (S, android 12), when I put my sim card in, it says “Emergency calls only.”
What can I check here to see what I’ve missed???

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I always run the First start wizard with the SIM in place.

You might try Factory reset with the SIM in place.

Unfortunately, a factory reset with SIM in place did not help…

This can happen when #apn has not been received from your carrier to your phone.

Simplest thing is to contact customer support and ask them to send APN to your device.

  • Access Point Names, the hash tag #apn will point you to similar topics.

The APN config appears normal. I’ve reflashed it multiple times with the stock firmware (latest Android 12 version for the CSC) and, while the APN’s look OK, the phone won’t register on the network. I’m going to try and flash just the modem.bin from another (older) revision to test a theory of mine…

Hi, does anyone experience a drop in internal storrage on the Samsung S10+ on android 12? Before I upgraded (on android 11) I had 512gb of storrage, now it’s only 32gb…
I also tried a 1Tb S10+ with the same result: only 32gb of internal storrage available.

This topic was automatically closed after 180 days. New replies are no longer allowed.