S4mini I9195 serranoltexx no mobile network

Hello everbody

Sorry if I use wrong terms maybe but I have no idea about all this stuff, I installed /e/ really with step by step instructions.

I flashed a Samsung mini S4 I9195 like 1 week ago. Installation went fine, I just had the issue that my Windows 10 did recognized the phone but I couldn’t put the installation file on the internal storage because the phone wasn’t showing up in the explorer. I put the installation file on a mini sd card and then booted it from there with TWRP. I did the flash with Odin.
Installation went fine, e worked properly. But I started it without my SIM, just fooling around a bit with the device (note: its the first time I have smart phone, until now I was very happy with a old nokia but they shut down the 2G network so I had to do smth and e is pretty cool:) I bought this phone second hand because its small (still too big for me!) Dont know if it was SIM locked, with the old software the sign of the carrier would show up by starting the device (i have different carrier) but I think flashing the device shut make this issue obsolet, I guess…

I startet the phone with a SIM in and since then I dont get connection, it recognizes my carrier but it says only emergency calls. Then I rebootet the device with the SIM in. This time it worked and I had reception and could do calls. But then suddenly there was no reception, again only emrgency calls (still carrier visible on the phone). I rebooted it now several times and its always the same on off with the reception. I tried like turning on flight mode, turn down mobile network, searching manually network -> takes ages to find, it finds the carrier with a SIM symbol but it can’t register in the network< I went to the phone options by ##4636## and trying another connection but it didnt’t work. Now its showing that it has signal but if I try sending a SMS, it can’t deliver the message.

Sorry lot of text but I trying to give as much information as possible to solve this problem, I really want this make to work, its a great project and I would love to have an e phone, so thanks for any suggestions!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have exactly the same device running the same e/OS/-build and no problems.
Just guessing: Is your SIM-Card LTE-ready? Have you tried 3G as “Preferred network type”?

Just a hint: When you connect your phone to your PC via USB-cable you must swipe down from the top. There’s a little field with a circled dot called “Android system”. Tap on it and change to “data transfer” or however it is called in English. You have to do this every time you reconnect. It’s a security feature, not a bug.

Did you check your APN settings ?
Salt help : https://www.salt.ch/en/device-help/?page=device/samsung/galaxy-s-4-lte/topic/mms/manual-configuration/1

How can I find out that my SIM ist LTE ready? I tried allmost all of this network types, didn’t help.
thanks for the hint, i tried it now, choosing transfer files but it still dont show up in the windows explorer (its not my main machine, i work on a mac)

Yes I checked, they were already installed, I checked it now, all the numbers and names were allready in except for the authentification type which I now manually set to PAP. I restartet the phone but still no connection

Sorry, I didn’t pay enough attention at first …

No, explicitely not! Flashing a SIM-locked device doesn’t remove the SIM-lock. I know it here in Germany from an old Samsung S II or S III mini branded with T-Mobile. You have to get the SIM-lock removed. The “brander” has a database. Maybe you can write a mail or fill out an online form.

Hope this helps.

When you can’t get an USB-connection for data transfer with Windows try to update the drivers with Windows update. Maybe manually in device manager.

Ok, I can ask the guy who sold it to me if it was SIM locked. But the carrier shows up on my phone and I did some calls (was some poor qualtiy though) meaning it somehow works.
I updated the drivers I even downloaded a program to get “better” drivers but still not showing up (this problem is not really bothering me as I have a way to bring data on the phone even if it is not handy. I don’t exchange much data on my phone, actually all I want is just be able to make calls and messages I don’t give much about all the other stuff a smartphone can do…)

There a plenty tutorials on youtube how to get rid of simlock but in my phone there is no message saying my sim is locked and the workaround they propose doesn’t work, the *#0011# doesn’t work on my phone

If you remember the provider whose logo showed up before go to provider’s home page and look for instructions to get the unlock code. You need the IMEI.
I remember that I put it into a form, sent it and some time later I got the unlock code.
That’s what I can advise.

Ok, I filled in the form, they will answer within 5 days, will see if this helps. Do you think I could get the IMEI nummber somewhere in the Net?

You can find the IMEI in LineageOS 14.1 (Android 7) under Settings --> About Phone --> Status --> IMEI-Information.
The provider has a database in which locked IMEI’s are stored. I can’t imagine that it is publically available.

(you are from D? you understand this?)

So no SIM lock, so is this the end? :worried:

Yes, I understand :–)
That’s a pity …

One more suggestion: Get a SIM from a friend and try in your phone and vice versa.
Maybe the SIM is not OK.
I can remember that some years ago one of my SIMs got broken when I removed it from the phone and put it back into the slot only some minutes later (maybe because of an electric discharge, shock or so). I had to request a new SIM from my provider.

Hey there everybody, if someone interessted how the story went on…

I’ve put a Lineage OS 17.1 on it (thanks to @npfp and arco68)


but the problem persisted.

I tried an older Lineage, but no progress as well. I then put an original stock ROM on it but on sammobile the S4 (or the one I needed) was archieved and you need to become a premium member (I didn’t want to) so I found somewhere in the web one which was for south arabia. But there the Problem still didn’t disappear (still only emergency calls). Then I found a tut on youtube. He suggested to reset the sim toolkit app. I had to reset all apps on my phone and it worked! But of course I didn’t want to stay with the stock ROM so I put back the Lineage 17.1. But there this method didn’t worked.

So I went on and saw on XDA, some modem files. I flashed the new or other modems files on it. This went not good. The phone booted and then a blue flash on the screen appeared and the boot stopped. Smth went very wrong, the phone somehow booted than later but then I had no Wifi (which never was a problem) and of course no provider signal. (ahh yeah, in the meanwhile I got a new SIM card from my provider but problem persisted).
I put back the stock ROM hoping to get rid of this boot issue but it persisted. Even with the firmware there was now no WiFi connections and no sounds while starting or locking screen (which is set from factory).

So I have somehow a phone not bricked but either not usable. For me the phone is more or less gone, I don’t know how to get rid of this boot problem. I guess I have to wipe really all of the data, meaning performing a NAND but I couldn’t inform myself about it but so far I doubt it will somehow contribute to the solution.

That’s sad … but at least this device isn’t very expensive at ebay etc. if you want to get a new one …
It’s never a good idea to flash a ROM that doesn’t fit your hardware and software exactly.
Especially Samsung releases many devices with the same name but different hardware.

The last official LineageOS for this phone was 14.1 / Android 7 (lineage-14.1-20180624-nightly-serranoltexx-signed.zip).
Maybe you could use this one as a base for further experiments?
I could provide it via Dropbox if you like.

If you are a “macrosoft windobe” user,
or a “linux/heimdall power user”,
you can try samfirmtool to restore you stock-rom firmware