S9 install problems

Hello, I’m new to /e/ and I’m trying to install it on my S9. But i’m currently getting a problem.
Whenever I type heimdall print-pit, nothing happens. It’s like an unknown system command.

Hello, welcome in our community :slight_smile:

Here is an alternative way to install /e/. Don’t forget to unlock OEM in development settings (in case it’s useful). I hope it still works on new Samsung device (and so with Android Pie as stock ROM).

Hello, It worked, but now I have error 7 when trying to install /e/.
I couldn’t understand your solution, on the guide. could you explain it differently?

Ok I now removed some of the sentences on the meta-inf file and sucessfully installed /E/.

Now there’s a new problem. The phone keeps restarting on its own after the samsung logo appears.

That’s weird because you have the last version of TWRP so if the error 7 occurs it’s probably not… an error.
Are you sure your smartphone is supported by /e/ ?
Codename: starlte


The fact the phone doesn’t start could mean you forced the installation of a firmware not compatible with your model.

Yes, my S9 is SM-G960F.

Ok. I don’t see where exactly could be the issue.

In the installation guide provided by /e/, there is a “patch the device” section and I have no idea about what it could be. So looks like my how to doesn’t work with new devices.

It had to do with the vendor img. I installed this one vendor img
And re installed, and it worked!
I’m now on the setup page on /e/ os!

Ok… Somehow, after installing with the vendor.img, the process went fine.
I am now a proud user of /e/.
Thank you for helping me!

1 Like