Samsung a5 2017 (SM-A520F) call and messages not working

I recently installed /e/ OS 0.18 on my Samsung A5 2017 (SM-A520F) “a5y17lte”
but the Calls and Messaging doesnt work. Everytime I try to call it says “Network Busy” and when messaging "Failed to send, Tap to try again. Althought the [Mobile LTE] works and I can access the internet.

So I tried do re-install the Bootloader and Modem with Odin v3.14.1 but it keeps failing to install.

Does anyone have any idea whats the problem here? Or how to fix it?
Much love!

i had this device and eos q install on it, i never encountered such network problems.
if you did not, i guess you should try to follow the instruction to flash via adb (heimdall, if i remember well).
good luck !

i’m not sure, but as far as remember, the instructions to install tools and drivers are on lineageOS website. and one more thing, the built need to be run as admin
let me know if i can help

I also tried flashing via adb sidload but still didnt work. And is it okay to install a different country/carrier? I need one in Korea.

you mean you still have the network issue or you mean the flash has failed ?
what do you want to install in korean ?

yes unfortunately i still have both issues, and I want to install a firmware but the Korean one is not available. So is it okay to install a firmware thats on the country are using your device?

firmware = stock rom (samsung) ?

I think so(?) im not sure but its from

which android version are you running now ?

/e/ os 0.18 android 11 but it was fully update to android Oreo 8.0 before installing /e/ Os.

a jump from 8 oreo to 11 r sounds weird
so you didn’t back up your original system ?

Oops nah i didnt back it up whatsoever…
Is it even possible to install android 11 on the stock rom?
and I think i wiped all my system rn. and im stock on the booting screen. LOL
maybe i should re-install

korean language must be available on eos
for stock rom, the only thing you need is enable the usb debug option so any language is ok
the problem is if your device does not accept that rom (region) and fail to flash

its not the language issue. the main issue is the Mobile service network doesnt work when I try to call and message. But the mobile network weirdly works. LOL oh man I think i also downloaded the “R” beta version for my phone instead of the “Q”. I’ll try to reinstall it with the Q version. And may I ask whats the difference with the recovery .img file and the zip one?

you need the .zip to flash, (i don’t know what’s the .img for)
do not rush, R > Q can brick your device
take the time to read all the instructions, i believe you indeed need to flash the stock rom first but please, wait for some advise/reply from dev or any other before to proceed.

edit : the recovery.img is a custom recovery from e

to my mind, if re-flashing eos r again (with heimdall installed) does not solve the problems, the best thing to do would now be to keep it as it is and wait for ota update.

I re-installed it with
Android Q e-0.18-q-20210827132307
its running fine but still the same issues with the [Calls and Messaging].
So Im gonna re-install the stock rom from samsung. And try to be more mindful this time.
I’ll also wait for the updates. Thanks a ton!

Update: I tried Samsung Stock Rom from xdaforums, and lineage OS. The Sim is detected but the All of the Mobile networks doesn’t work.

Foreign stock samsung firmware could not use the same bands, but surely don’t content the right APN.

For data mobile connections problems, have a try with dial to *#*#4636#*#*

I tried dialing the numbers, i selected LTE only on the “Set Preferred Network Type” and the mobile data works now! But the Calls and Messaging still doesnt work. And so when I [Select Radio Band] all of the options says “uncessful”.Even the Class 4 (Korea-PCS) and the Automatic.

Roaming: Not Roaming
Data Service: Connected
Data Network Type: LTE
Voice Service: Emergency Calls Only (this is the problem)
Voice Network Type: LTE

reply/ i reached the limit for reply LOL

Uhm the mobile data works now i can access the net. But i cant call and msg.
Where can i see the provider APN settings?