Samsung Galaxy A52 (a52q) fingerprint enrollment not workingsa

On a fairly freshly ( /e/OS 1.14 ) installed Samsung galaxy A52q the fingerprint enrollment always fails, see screenshot attached. Is there some thing I can try to fix it? It worked on stock version.

I updated the phone to Android T (e-1.15-t) and fingerprint enrollment magically works :person_shrugging:

But did not survive reboot and now seeing similar issue :disappointed:

The fact that the fingerprint recovered on upgrade, gives the idea that you might simply need to clear and reset the fingerprint (perhaps you already tried ?). Not sure the location of this task; does it appear in the Search facility of Settings ?

I have the same issue on my galaxy note 10+, with android S. I just reinstalled the OS today.
It worked on previous version.

I found a solution on XDA forum :
https://xdaforums.com/t/rom-official-11-lineageos-18-1-for-galaxy-note10-note10-note10-5g-exynos.4311283/post-85434057

Not working for me as I ended up in some strange cycle where the enrollment immediatleyfails with the same error as mentioned above …honestly this device is giving headaches and is not working great, pictures are not looking particularly great, volume in the calls sometimes suddenly drops. This device is not really stable at all.