Samsung Galaxy S3 GT-I9300 bought in Sweden

Hi.

I have Samsung Galaxy S3 GT-I9300 bought in Sweden, from the Swedish phone carrier 3 www.tre.se

About this phone /Screenshot
https://www.screencast.com/t/7mwEpqq1uF

I’m very uncertain if e foundation will work on my phone or if it would be bricked…

So my simple question is of course if this would work on my phone?

As you can see it is still running the original Samsung rom which it came with.

Thanks in advance for the answer.

Kind regards
PowerQuest

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @PowerQuest,

Your device is compatible and still supported :

Thanks for the reply guys.

I’m still a bit worried.-- :thinking:
I cannot get the OEM Unlock to be displayed in the Developer menu. I did also follow the guide that was linked above to that subject. But with no change on my phone.

Thanks a again.

Kind regards
PowerQuest

The allow bootloader unlock feature was not present on the Android 4 version, continue the install process, don’t care about the « developer option OEM» feature, just allow adb in the dev option

Édit : do you use Heimdall or Odin ?

After flashing TWRP, you have to launch it before something else be launching. If it is not the case, TWRP is overwrited by Normal mode Boot or Samsung Recovery mode Boot.

to be sure to reboot into TWRP after flashing it, you ‘d better manually turn off your device : unplug the cable and press the « volume down » and « power boutons »,
then boot in TWRP with « volume up » plus « home » and « power » boutons
( if you use Heimdall commands, don’t forget « no reboot » at the end, if you use Odin don’t forget to deselect « auto-reboot » in the option tab.)

Thank you so much for your kind help @piero.
It is very appreciated. :smirk:

I’m on Windows 10 so I do not have Linux, so I suppose that using Odin I guess, is the safest route, right?

Is there anything specific I should consider when using Odin by the way?

Kind regards
PowerQuest

Hi guys…

Ouch it failed:


and i have no idea why…

Any help with this would be appreciate. Everything worked fine until the last step and the followed the installation guide carefully. It’s referring to the sdcard what what I can see?

I used the international Europe version of TWRP: https://eu.dl.twrp.me/i9300/ and the latest version… (twrp-3.4.0-0-i9300.img.tar)

Is there anything I can do to get this to work or should I just reinstall the stock rom, (I have that too). I have no idea what to do next to fix this.

Thanks a lot in advance.

Kind regards
PowerQuest

I can’t remember which twrp version I used, but for sure not the 3.4.0…
I do not have my i9300 hsndy. I will tell you in a couple of days.

As far as I remember it was a version before the one suggested in the /e/ guide

Well I figured it out by using this guy’s tutorial:

The trick was to use an older TWRP version: twrp-3.0.1-0-i9300.img.tar
and then fully format the phone --> reboot to recovery --> Format the folders:

  • Dalvik / ART Cache
  • Data
  • Internal Storage
  • cache
  • system
    and then run the installation.
    And boom - it worked! :smirk:

and now it is installed… :smile:

Pretty nice! :+1: :smiley: