Samsung Galaxy S8 bootloop for no reason, somebody can help? (bypassed)

Hello everyone !

I installed /e/ on the Samsung S8 (dreamlte) phone of a friend on mine, following the tutorial (with e-0.12-p-2020102981459-dev-dreamlte version and TWRP 3.3.2-1 though, the last TWRP version wasn’t working).

The phone worked perfectly (and she was really happy with /e/ ) for few days but this morning she woke up with the phone on TWRP. When I tried to reboot it stayed one minute or two on the /e/ logo and then TWRP. When I power off the phone and wake it up it goes directly to TWRP.

I try to copy the logs on the SD card but I can’t find them, do you know where it is stored ? is it this file mercury.db ?

Does somebody knows why is it happening since everything was ok ?
How can I fix the problem ?

Thank you in advance !


hopefully you speak French, I haven’t translated the following HOWTO yet:

Also, you could re-install /e/OS with the easy Installer (this way your friend will be on the stable branch instead of the dev one), but data will be lost.

Thank you for your answer.

I first tried to use the easy installer on her windows laptop but it didn’t work. So that’s why I manually install it from my linux laptop. The manual installation didn’t work with TWRP 3.4 (the last version) so I suspect this is why it didn’t work with the easy installer either.

I didn’t know there was a stable version of the rom, why the stable isn’t available for the manual install (or why it is not mentioned in the tutorial ?). Do you have a direct link to this rom ?

Anyway, I’m trying again the install with the easy installer from my linux laptop this time (but you made me install snap, what a shame :scream: #justkidding ). I’ll let you know !

Thank you again !

Installing the stable version worked this time with the easy installer so I hope the problem won’t happen again.

I don’t think the tutorial in french would help, as I already tried almost everything but doing a factory reset (to void having to reinstall all the apps)

(and yes I speak french btw)

Anyways, thank you for your time !

The builds of the stable branch are for e/shop device and the release is délayed for a few weeks from the dev one in order to have time for the beta-testers community to detect problems

So there is no difference between the second last dev version and the stable version. Thank you for the explanation.
Should I report the bug on gitlab even if I wasn’t able to get the logs and I reinstalled a fresh system on it ?