Samsung Galaxy S9+ help request

Hi everyone,

My name’s Buffy and I’m a total newbie when it comes to operating systems and programming and all this. But I am really concerned with privacy and really want to get e/OS on my phone.

I bought a Samsung Galaxy S9+ especially for this purpose, downloaded the software to my laptop and then followed every instruction to the letter. The software recognised the phone and I found the easy install system incredibly helpful. Every step of the way it was competely accurate in describing what I would see. The steps were really clear, I followed them and I got all the way through to the congratulations screen saying it was all done.

The trouble is, now I’ve booted up the phone, when I look in the settings it is still saying my OS is Android!! Did I do something wrong? I was absolutely sure that I followed every instruction for boththe computer and the phone because I was impressed with how clear they were.

I know nobody can see so it’s gonna be difficult for you to offer any advice but can anyone offer any pearls of wisdom?

Thanks ever so much.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello Buffy, and welcome !
If you did see the bouncing “e” and then the “my data is my data” message at boot time … then all’s right, your phone is running /e/OS :slight_smile:
And actually /e/OS is an Android-derived OS : it’s based on Android Open Source Project (aka AOSP).
Just as the “average” Google Android … but without Google propietary software layers that steel your data :slight_smile:
Enjoy !

Congrats and welcome !!
I see no problem here like @jpmeuret said /e/OS is an android OS too.

Angain welcome in the /e/ team :slight_smile:

Buffy, simple check, go into Settings>System updates, it should say /e/OS. You may even have an update waiting.

Thanks so much for the replies! Sadly I saw the bouncing e on my computer screen but not on my phone.

I just checked and apparently my software version is: G965FXXUHFVB4 /G965FOTFHFVB2 / G965FXXUHFVB4…

I have no idea if this is right or not lol.

I guess I could start over and try it again…

Thinking back, the only problem I had was with the fastboot driver bit. If I’d got that wrong would it mess everything up? I found the advice not very clear- is it a driver for my phone or laptop?

This is what the website said:

For Samsung phone, there is a external tool called “wdi-simple.exe” provided with easy-installer. It will be called during the process when required and install the driver your need to work with heimdall.

I was exceeding the easy installer to say- you need this driver, but it didn’t.
The easy installer guidance mentioned needing some driver but then as I looked into it out seemed to then say- aha! We’ve identified your phone! So I moved on.

What is this driver and how do I get it where it needs to be?

I’m ever so grateful for your help everyone. Really truly.

I have 2 phones, neither worked first time, three of four attempts each.


So you are using Windows? It will differ with different Windows version, but you open a Device manager window, and look for your connected phone. What you don’t want to see is a :warning: Problem device. Now boot into Recovery, look for your device, now boot into Odin mode aka Download mode, if at any point you see the device in any mode :warning: as a Problem device, you can run Windows update, a suitable driver should be found automatically and :warning: has cleared. If no :warning: is seen you are good to go.

If the Wndows searched driver did not clear the problem. There should be an option to provide your own driver. I do not use Windows, but loosely you download the recommended driver, and select it in Windows update at this point.

Maybe you used “fastboot” loosely, or maybe one of our pages has an error. You cannot use fastboot commands with a Samsung. We have Odin / Heimdall as the communication channel. There should be no fastboot commands used.


Thankyou… I’m not 100% sure what much of that means but I’ll plug my phone in and have a go!

Where would I get this driver from? Is there a website you go to our do you have to type a load of code in?

So grateful for your support!

Easy Installer should be self contained and just work. There is certainly no code to enter manually. A high proportion of Easy Installer jobs just work.

I have to say that I did not fully understand this part of you post

Quoting from

For Samsung phone, there is a external tool called “wdi-simple.exe” provided with easy-installer. It will be called during the process when required and install the driver your need to work with heimdall.

(my emphasis). So it is built in to Easy Installer.

There is nothing to do!

The little check that Windows does not see your Samsung as a Problem device may reassure you that there is no problem.

(The documentation changed recently, I remember a utility called Zadig mentioned and I thought you had been thrown by that. This is in fact no longer seen. So no problem there.)

This however is a new page to me and I now see where you got the idea " Install fastboot drivers"

This page seems unhelpful as Samsung does not use fastboot! The page just says Easy Installer is self contained, again, nothing to do!

If you want better general understanding, drivers are a Windows thing, Microsoft offer this

Edit. Just re running Easy Installer is probably the best thing to do. If I read it right “wdi-simple.exe” will organise the Windows update of drivers for you, so unless you got some error pointing to a driver, it should not be an issue! Nothing to do.

Hi everyone, sorry I’ve been away for a wedding- am back now and trying to sort this out!

Confused did you try anything different with each of the four attempts you made, or did you just do the same thing over and over again?

You’re right aibd the driver is indeed correctly installed on my computer. Sorry about my predictive text error, I meant to say: “I was expecting the easy installer to say I needed a certain driver”. My mistake.

I keep trying the easy installer, but with no success. I’ve realised that not every stage is happening as per the instructions. My biggest concern is at the stage where e/OS is downloading. I get the blue download screen which says “Downloading… Do not turn off target”. The computer screen jumps quite quickly to instructing me to press the power, bixby and volume down buttons to turn the phone off, but underneath the “Downloading” sign on my phone it says that if I press volume down and power it will cancel the download. Is this my problem? Am I jumping the gun? Do I need to wait until the phone stops saying “Downloading”? If so, how long do you think that will take? I’ve already tried leaving it for an hour, but with no change.

So sorry to keep asking for help. ARGH. Thanks for all your comments.

It is not about downloading /eOS from the internets, it is about forcing the loading of the e-recovery manager to the phone, it takes less than 2 minutes…

No, it just won’t allow the phone to accept being flashing, and perform a normal boot.

Your problem is probably more related to rebooting immediatlly in recovery mode.

TWRP first boot explanation by @aibd

So am I right to interrupt the download screen I’ve uploaded the picture of?

1 Like

Thankyou! I’ll try this tomorrow.

Ok- I’ve had a small amount of success! Thankyou for all your advice!

I seem to have progressed to another problem though in the app store which is opening but then not fully loading up so I cannot access any apps. Panicking that I did something wrong…

Im thinking I may need to start a thread on a different section of the forum though, but thankyou to everyone for your advice and support. The extra forum pages were so helpful.

App Lounge seems to require a very clear line. Speculation, the server may time out silently in busy times. (European time zones.)

You could try F-Droid or Aurora store. Many users prefer these over App Lounge.

Also be sure to have Advanced privacy off when using App Lounge.

1 Like

AH! It’s working so much better now. I had Advanced Privacy on and it slowed it to a snail’s pace.


1 Like

Glad to see that you did it !

Welcome to the club :wink:

1 Like