Samsung Galaxy S9+ (SM-G965F) /e/ installation TWRP blocked (RMM STATE: Prenormal)

Hi @Aibd,

I managed to use the below old link to go to TWRP but I forgot to download the /e/ zip files to my phone before. So I need to go back and reboot from the system since I don’t know what to do next.

My questions now is the instructions for the manual installation are different between this old link and the new link as below:

So does it mean that I will be able to install it if I follow the instructions for manual installation? Do we need to run the commands for Heimdall?


You have to fisrt properly unlock the bootloader

Firstly thank you for wording your report so well – with RMM STATE : PRENORMAL the solution is so hard to find in an online search because there are so many causes but owners cannot tell what is their blocker !

Carrier locking now looks the favourite – thanks @piero – please can you contact TELSTRA support and ask them to unlock your phone. Generally, in Europe, if your have owned the phone for over 12 months, this is just a formality, sometimes with a few arbitrary hurdles on the way. I imagine you could tell then that you do not actually want to leave their service just have the locks removed.

Good luck

Hi @shoukova welcome to the /e/ forum.

I am going to ask you to redefine “the same problem” so I reduce the amount of nonsense I might write ! You are in Australia ? Exactly what else is in common with the OP ?

You mention EMEA – do you think yours is a grey import ?

An image of your Download mode screen may throw some light, but I assume that you are seeing RMM STATE : PRENORMAL or KG STATE : PRENORMAL or KG STATE : Checking ?

I would prefer to answer your further questions with the full picture. Both tutorials are valid – the different approaches are mostly due to the fundamental difference between Linux and Windows. The manner in which Samsung shroud their methods by asserting that Odin is leaked to Windows and nothing to do with them does not help document writers !

Regards rooting, while connected to the wider subject, /e/ does not require or expect rooting – I like to avoid it as an exploitation method for /e/.

What do you mean by “properly unlock the bootloader”? I did press the three keys according to instructions…

Hi @aibd,

I mean I can’t login to TWRP screen using easy installer after the download. I’m in HK and got that EMEA exynos S9+ SM-965F. I don’t know if it’s becoz of the regional lock as you mentioned. I don’t RMM State at all.

But I did get into the TWRP screen once when I followed the steps in the below link for old phone, of course with update img / tar files for S9+:

However, I noticed I forgot to downloaded the /e/ zip file for S9+ at that time and I chose to reboot it to the system.

When I compared the /e/ installation for old model SM-J500FN with the updated instruction for command line installation for S9+ (, I found that I needed to install a custom recovery by heimdall. But this step was not shown in the installation guide for SM-J500FN. So my questions are:

  1. Can I just follow the old installation guide for SM-J500FN but with the update files for S9+?

  2. I notice the difference on “wipe” the data on the phone. Should we follow the memory wiping guidelines of SM-J500FN for S9+ as below?

  3. If I wipe away all the data but fail on the installation in the end, will I still be able to reboot back to system? Is the disc image file “recovery-e-0.23-q-20220406175186-dev-star2lte” the same as the Samsung ROM file downloaded from sammobile site? The Samsung ROM file for S9+ is missing on the sammobile site.

  4. Is the command line installation the only way to install /e/ OS on S9+?

Thanks so much for your assistance and patience.

Hi @shoukova I am sorry that my reply is going to sound negative to you but I would like to help you get your phone running /e/ but on a different thread to avoid further crossed wires !

As a new user of the forum you may not be able to do this. Please can you try to return to your last post with “Edit”. Can you then copy and paste its contents to the new tread which I will open and link. If this works, please can you later delete the post here. Please standby, thank you.

Samsung Galaxy S9+ (SM-G965F) TWRP fails for reason unknown @shoukova you may edit the in initial post if this works for you ! Thank you.

I’ve copied and pasted the content to your new link. Pls have a look. Thanks.

Hi @aibd and Bonjour @piero ,
Thank you for your response.
I have tried a different network SIM card and I was able to perform a phone call so my mobile is definitely unlocked :slight_smile:
What can I try next?

Have all forms of Prenormal disappeared from the Download mode screen ? In which case you are free to take whichever seems the easiest install path.


It is a bit of a leap for me to suggest TELSTRA is responsible for your locked bootloader – this is separate from a locked SIM. The term Carrier locking is often used referring to SIM locking, but it can occur in Carrier bootloader locking too.

I mean avoid the prenormal state

@aibd I haven’t changed anything on the phone since my first post on this thread :slight_smile: the phone was unlocked since I purchased it (SIM card) by the 1st owner.
RMM State hasn’t changed, it still shows “Prenormal(see image below).

@piero if you could please give some advice (even in French) on how to avoid this Prenormal state, je suis tout ouïe!

@aibd if you think there is nothing I can do then I’ll just abandon here, I have already spent many hours of deception into getting /e/ OS on my S9+ :pensive:

I understand. Re TELSTRA, as a one time stakeholder in the device – and, they might have had RMM installed by Samsung as part of their contract of supply … did you decide not to ask if they might have applied carrier bootlocking.

I have tried to contact Telstra but as I’m using another carrier SIM I couldn’t access their support team so I have to do without them unfortunately :sweat_smile:

Hey, I found this in researching your issue ! It is from Hong Kong; ideally you would try to find your “local” support solution from Samsung, if there is any possibility of lifting the lock without the help of whoever applied it ! Edit, I now suspect that the clue in the title here is that this will potentially start a new RMM :blush:

Hi @aibd thanks for getting back to me. I will try to contact the Samsung support team on Monday.
On my side I continued looking for solution and I have found in another forum that other people are having this issue on S9/S9+ updated to the latest security patch.
I have looked at this forum too but couldn’t find a solution to my problem yet.

Should I try to install a specific version of my stock firmware to see if it could fix the issue? If yes which one do you recommand from the below?

I will reflect on that; at first sight is this suggesting that some ROMs mimic what we see on Galaxy S10 series phones where there are special very specific Pre-Install Instructions.

Perhaps you could see if in any way the advice in Pre-Install Instructions here Install /e/ on a Samsung Galaxy S10 - “beyond1lte” could apply to your device. (A bit of a long shot ! )

Aside: that corsicanu link is ineffective for Andoid 10, he does have a more recent link to workarounds for the Galaxy S10 series [RECOVERY][OFFICIAL][3.6.1-x] TWRP for Galaxy S10/e/+/5G Exynos | XDA Forums.

If your device is simlocked by the carrier, TEL is needed to unlock the phone.
Then you can flash XSA (global australia) if you prefer ( less bloatware in comparaison, but as you will wipe /system and /data, gain is relative )
Or the one according to you new carrier ( possible network access gain )

If your device is already carrier unlocked you can choose TEL or XSA or the one according to your new carrier

@piero thanks for your detailed response. As mentioned above in the thread, my device is not sim-locked so I might give it a try with the XSA version and see if this could change the RMM State (currently Prenormal) that is probably the reason why I can’t boot in TWRP.

@aibd thanks for your advice, I’ll have a read and see if there is anything that could help me with my current issue here.
I saw that other people might be having the same issue (ref to the latest message on this thread).
It might be worth for the /e/ team to have a deeper look at this topic.