Samsung - Galaxy S9+ - star2lte - Documentation Suggestions

Please add your suggestions to improve the documentation for the Samsung - Galaxy S9+ - star2lte here …

J’ai suivi le tuto ici
Model SM G965F
Version de base G965FXXUAETG3

Je suis sous Ubuntu:
OS: Ubuntu 20.04.1 LTS x86_64
Host: HP Pro 3400 Series
MT Kernel: 5.4.0-48-generic Shell: bash 5.0.17
DE: Cinnamon cons: gnome [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-2400 (4) @ 3.400GHz

J’ai rien à signaler à part avoir fait les mises à jours jusqu’à 10 avant de le rooter, j’avais pas lu qu’il fallait pas le faire…
Donc j’ai planté en mode manuel pour flasher la rom…
J’ai donc tenté par easy installer et là…super fluide, du vrai pas à pas
Ca a marché du premier coup, rien à redire

1 Like

Salut @JeanGui,
La procédure par l’easy-installer n’inclut pas le « root » car /e/ s’execute sur des appareils non rootés

C’est une autre procédure qui consiste à flasher l’apk de magisk a l’aide la fonction install de TWRP.
Après redémarrage, c’est Magisk qui donnera le root au cas par cas à certaines applications seulement, tout en cachant cette possibilité a certaines autres applications.

Ha bin j’ai pas fini moi alors

instructions I think should be added to this part of the install doc

for windows 10 systems:

  1. open control panel

  2. click on system

  3. click on advanced system settings
    this will bring up another window labeled system properties that will be open on the advanced tab

  4. at the bottom of the bottom of the window click Environment Variables
    the Environment Variables window will open

  5. highlight the row that says Path then click Edit…
    yet another new window will open called Edit environment variables

  6. click new and add the path to the folder
    ie C:\e os\platform-tools

  7. click ok
    now the programs in the platform-tools folder can be run from the command prompt

“Before following these instructions please ensure that the device is on the latest Android firmware.” The firmware file linked in the installation process is not working, so no update is possible. I have no idea how to update the firmware without additional information.

The TWRP version that is suggested is not able to decrypt the file system. So no full backup is possible. Is there any way to do an update on an encrypted device without loosing all date? Is an newer TWRP version suggested? Is it possible to update TWRP without harming the OS?

1 Like

I installed my S9+ using the easy installer. Now I want to upgrade to Android Q version.
So following instructions here

But when I try the sideload, get error “Vendor image on device is NOT compatible, Expected Android 10 vendor”.

I found this question which links to lineageos wiki installation instructions - they say " Warning: Before following these instructions please ensure that the device is on the latest Android 10 firmware."

Sooo, how do I get my phone from its current state as provided by easy installer, to “Android 10 firmware” state?

It seems that in order to “Upgrade” to android 10, the phone must already have android 10 installed? This makes no sense!?

I think the easy install should notify that it is necessary to upgrade the stock Samsung image to Android 10 BEFORE installing e OS. If I had followed the manual install instructions I would have seen the big red warning about this. As it is, I thought “I’ll try the easy installer, sure it will get me the latest, or I’ll be able to upgrade after switching to /e/.”. Silly me

MMS Messaging - Samsung Galaxy S9+ -SM-G965F for U.S. Users

/e/ 0.16 - Oreo 8.1.0

The DUAL SIM PHONEs need to be properly configured especially if they are only using 1 SIM.

There were two things:

#1) Even though under settings->Network&Internet->Sim Cards->SIM slot 1 was selected and SIM slot 2 is empty.

However under preferred SIM for:

Mobile Data
Card 1

Ask Every time

SMS Messages

You have to set the SMS Messages to CARD 1

All of the other settings are set automatically to CARD 1. However, not the SMS Messages.

#2) Ensure you have the proper DNS settings.

Network&Internet->DNS. You have to use the network DNS. You cannot set the DNS to something like (They may not have the Domain name of the APN MMC)

Hello, for my SM-G965N I followed the tutorial up to ‘adb sideload’ but I get

E: failed to verify whole-file signature
E: Signature verification failed
E: error: 21

What are the likely causes ? Did I skip a step ? Am I missing something obvious ? Something about OEM unlock timing ?

In case this helps with understanding the context, the recovery boot tool header says:

Android Recovery

I bought this precise model because I read that the “Easy Installer” supports it… I’m disappointed it doesn’t. “Your SM_965N is not yet supported by /e/ OS”

Hello. I’ve noticed two places where the instructions can be more clear:

  1. Preparing for installation using Heimdall, Step 5.4. appears to be incomplete:
    “Click Replace Driver (having to select Install Driver from the drop down list built into the”

  2. Installing a custom recovery, Step 4.
    Why are --RECOVERY and --no-reboot in purple? Should they be typed into the command
    prompt as well? If so, please change colour to black. If not, please remove this from the command
    prompt information.

Also, it appears as though these instructions are translated from another language.

Thanks! I have ordered a Galaxy S9+, and I am hopeful that I am able to install the latest /e/ OS available for this device. :slight_smile:

1 Like

Under Requirements one point is “Enable USB debugging on your device.”
The link shows both USB debugging and OEM unlock, which is correct, both are required.
Users with USB debugging already but without OEM unlock, such as me, can miss the OEM unlock until they get the error message. Please consider changing “Enable USB debugging” to
“Enable USB debugging and OEM unlock”.

The instructions seem generic, it would be helpful to some to consider including the current version.
This device, Samsung Galaxy S9+ can be updated by Samsung to Android 10. The current stable and development versions of e are also Android 10.

Small point, but Android stopped using names and letters and is now using on version numbers, such as 12, 13 and 14.

I also want to thank the developers. My original phone, the fingerprint reader seemed to not recognize my finger most of the time. Now with e, it hasn’t missed and opens instantly. The camera also looks great and the features are impressive. I’ve installed a few apps from the App lounge and all work nicely. This current version,, is very impressive. Well done and many thanks.

Hey first i wanna tnx you guys for making this e/os its wonderful im using e/os on my s9+ for the past 1 year as my primary os is totally good but in the recent update 1.14 its heating a little bit while using camera not while recording if i just open the camera its starts to get hot little by little i hope in the T Build you guys will fix it

Also i hope to see the dolby audio in the T build

I tried to update to the new version 1.15 based on Android R aka 11. The OTA download process proceeds smoothly, but after rebooting it does not perform the update, but crashes at the download screen (I have to manually press the power button+volume down for 7 seconds to exit). I have tried with both the available updates of 14 and 15 September.
Any ideas?

I successfully did a manual update from e-1.15-t-20230918331436-dev-star2lte to e-1.18-t-20231210360971-dev-star2lte. I first installed e-Recovery ‘T’.

:new: recovery.tar.md5
generated from the official e-recovery recovery-e-1.18-t-20231210360971-dev-star2lte.img