Samsung Galaxy Tab S2 SM-T813: cannot connect with adb

Hi all,
I’m in trouble wit my Samsung SM-T813 with eOS

I need to use the tablet for teaching, so in the past I connected it via scrcpy to a Linux Mint and used it with the app “markers” as a electronic chalkboard.
I only checked that everything was fine with the cable, software and all may be in September. I was very satisfied of the results.

Apparently nothing in the hardware has changed (computer, cable and, tablet), nor in the eOS (august 14th) but I can’t no longer connect the tablet to Linux.

But my S8 eOS phone is recognized and scrcpy works as expected

adb devices
do not recognize the tablet when connected and

  1. same original samsung cable
  2. same computer
  3. usb debugging enabled both in phone and tablet

In the tablet I can see the USB preferences, but the 5 options are shadowed (file transfer, tethering, MIDI, PTP, no data transfer)

Under "Developer options -> Default USB configuration ", the option “file transfer” is enabled and I can choose among the 5 options.

Either I hit a bug or (most probably) I’m missing something obvious.

Any idea ?

Did you try to setup USB as “Charging only” (no data) by default ?
What about another computer/OS ?

Thanks @smu44. No way for another OS , but I will try your suggestion and report here the results. Same results on two different Mint versions on two different machines

There is a « normal » (not développeur) feature in >settings, search for « usb »

Thanks @piero. The problem is that normal USB preferences are not selectable. See the attached screenshot

For @smu44: unfortunately if I select no data transfer in USB developer settings, adb devices still do not recognise the tablet. And this is quite expected, I suppose.

I am running a test version with a very similar date to yours on a Samsung A3. This is probably an outside chance, but I did not understand why I had USB preferences greyed out, but USB configuration active (and I think under control). I have had other builds on the phone and have not made notes but I think this USB behaviour is variable.

I had assumed that it was user error and included the fact that at one time I had my SD card installed “as internal storage”. I once intended to reformat the SD card to rule out that issue but it has not been done.

I don’t know if you think it would throw light on the issue to see if the tablet behaves the same with and without SD card.

Thanks @aibd. SD card removed, but still USB preferences did not change

Same here with USB Preferences :frowning: And ADB working like a charm.
Looks like an old trace of some stuff that is no longer active …

About “No data” : this is a userland parameter, which can sometimes interfere with ADB. So I thought you’ll get more luck setting it this way.

Without a Windows computer :wink: you may try the hard path : try sudo dmesg --follow on your Linux computer, then plug tablet.

Also, if your tablet supports it, is it “seen” by computer while in Bootloader/fastboot mode ?

Thanks again @smu44,
Nothing happens on dmesg nor on lsusb. But when I connect the S8 phone, both commands give the expected output.

No: it’s not seen in fastboot mode, same missing output from dmesg and lsusb

You’re more likely facing a hardware or firmware problem on your tablet, sorry :frowning:

As a workaround you can use scrcpy on-air :
Hint : instead of adb tcpip 5555 command, you can use the “ADB over network” switch in Developer options.

Tip : using the same method, you can try adb root, adb shell then logcat, this may help to debug USB problem :wink:

I hope I understand you right. You and other Users can’t change the USB Mode on their SM-T813 because it’s greyed out.

I have the same tablet here and want to help troubleshooting.

My Setup

  • SM-T813
  • Official /e/ test build 0.10-p (English installation)
  • No SD-Card inserted (never was)
  • PC running Solus (Linux)
  • PC running Windows 10 20H2

Behavior with Linux:

  • lsusb detects the tablet as “Qualcomm, Inc. Nokia 8110 4G”
  • When I connect the tablet, the USB mode is charging
  • I can change the USB mode to filetransfer
  • Storage gets automounted and I can access the internal storage

Behavior with Windows:

  • When I connect the tablet, the USB mode is charging
  • I can change the USB mode to filetransfer
  • Storage gets automounted and I can access the internal storage

I haven’t had Developers Options activated, so ADB didn’t find the device. I activated them, turned on Android Debugging and adb devices immediately finds the device.

When I insert the USB cable, it activates debugging, in charging or file transfer mode.

Only situation I have greyed out options in the USB menue is when no cable is attached.

I think the first step to troubleshoot this should be to wipe the caches in TWRP.

I will try this, thanks @Ludix. Could you please post a link with some directions ? I’m an old Linux user, but a noob in TWRP and flashing ROM

@Ludix, thank you for that. I confirm that in on my phone on “pie” USB preferences is greyed out until a cable is attached, then immediately come alive. That was news to me! Thanks.

Wait !! Thanks to you all, and I apologize for causing troubles.
I tried also on a Win10 machine, but I’m the very same situation; s8 is connected and Tab S2 is not.

I’m now remembering that the USB cable, even if is a Samsung original one, is not the one which was coming with the tablet.
May be is due to that: never had connection problems before, but I cannot remember which was the cable used. The white original one was broken, badly closed on the rim of a drawer. I will try to get a proper one - hopefully ! and report here.
I also have to try the OTA stuff.

Yes, some cables are just good for charging. That’s why I included the behavior when no cable is connected.

I think in this case you don’t have to wipe the cache. If it doesn’t work with another cable, we’ll try further steps.

Looking forward to your update!

Yes, I know the difference between cables for data transfer and those for charging only; I have many of those last.
That’s why I’ve been always using a Samsung genuine Data Link cable APCBU10BBE, which works flawless on a S8.

I went to ebay where a myriad of cables are available. Someone of you guys could be please so kind as to give me the model of the cable which works for the Tab S2 ?

You should use the original cable with model number EP-DG925UWE. I found this number in the original packaging of my Tab S2. However other ones should work as well.

Thanks @JPTabS2. I’ve finally found the culprit(s).

I bought a data cable here in my local supermarket for the ridiculous amount of 3.90€. Now everything is working as expected.

It works also with the genuine Samsung APCBU10BBE cable, but only if I keep my finger under the plug, sustaining - so to say - the whole weight of the tablet.
Thanks to you all for your valuable help