Samsung - Galaxy Tab S6 Lite (Wi-Fi) - gta4xlwifi - Documentation Suggestions

Another thing to watch when installing from LinuxMint is to make sure you are on Heimdall 1.4.2. I tried it first with Heimdall 1.4.0 since that is what most installers you can find are for. Heimdall would not communicate witj the device until I upgraded to 1.4.2. I think this would apply to most Ubuntu distros to need 1.4.2 for it to work properly from what I read elsewhere.

I just finished flashing. Once the recovery image was flashed, everything went very smoothly.
But before that I ran into a few issues that might be clarified further in the documentation.

  1. Make sure that you stay connected to wifi at all times. This might reduce the chance that a Samsung device sinks into ‘Prenormal KG/RMM state’, and this could potentially halt the installation process for 7 days. (Also, it took me some time before I realised that I actually was in prenormal state myself, so it is good to emphasise
    checking whether the OEM Unlock toggle is missing.)
  2. I didn’t get Heimdall working after many, many attempts. I agree with @Luke to suggest the alternative ODIN install for Windows users. This would make the process much smoother.
  3. Me, personally, I didn’t want to use ODIN this time, as I thought I had to first manually flash TRWP as well; (this is suggested in another forum thread ). But because I couldn’t find the right version for the S6 Lite, I didn’t want to go there initially, until I got really fed up with heimdall. So a side note that manually flashing TWRP is not needed here, would have made the installation easier.

So far my suggestions, hope they are useful.
The rest was really super smooth!

(And now i am going to play with my first-ever, privacy friendly tablet. :smiley:)

1 Like

I also could easily upgrade my tablet with the official instructions (adb sideload), from a r version to 1.14-s

It’s real relief to not have to re-install/re-configure/re-transfer everything…

@Luke Thanks for this fantastic tip which worked a charm and got me out of a download mode boot loop.

I think the install guide for this tablet should link to your post for a Windows/Odin installation rather than to the existing How To which is seriously out of date and does not work with this model. If you follow the Odin/TWRP route as suggested, you will end up in a boot loop like me.

The doc should be upgrade,there is an important missing step as describe here

The OEM unlock method isn’t right on the doc.

In de instal guide it tells to upgrade the device, so I did. Now it’s on A13 and can’t install latest e/os version. I tried downgrading to A12, but without luck.
Probably a good idea to change the install guide to carefully or manual update to A12. Or is there any way to install the S version of e/os?

1 Like

There is anti-rollback feature, so downgrade might not be possible.
So either you wait until /e/OS-T for the device is officially released, or you use my unofficial build:

1 Like


I’ve download 1.21 to install via sideload, followed the same procedure as always (Enable USB Debugging on your phone, Plug your phone to your computer making sure to use a good usb cable for data transfer, Open Terminal), then typed adb reboot recovery and it went on a boot loop.

Any suggestion on how can I stop the boot loop?