Samsung Galaxy Tab2 espressowifi (two models 7 & 10)

Good deal :+1: thanks @Android-Andi

So this finally became a thing lol. I wonder if this supports Andi’s overclocked kernel.

Btw where are the links to download. And don’t push Andi, his services for a 8 years old tablet is more than enough

Hey Andi, do you think Android One is possible for our devices? Or it’s just too slow?

@dogukans Android one is something completely different.
I don’t think Google likes to push updates :wink:

But yeah, I know it could boot Oreo.

There’s no public version of /e/ available for tab2 currently.
BlissLauncher for example looks odd on p51xx… As they are landscape devices and the workspace does not match and looks really odd. Maybe @arnauvp could also have a look at this:

It needs a landscape layout.

If my AnyKernel is supported depends on used sources to compile the ROM, official LineageOS sources use a older DDK and won’t work with it (not sure if I’ve ever uploaded an OC kernel for old ddk ROMs, but sources are open for everyone if someone needs).

And please note:
Any kind of OC is really dangerous on Galaxy Tab2. While OMAP 4460 (used on the Galaxy Nexus for example) has a built-in temperature sensor, OMAP 4430 (Galaxy Tab2 uses) doesn’t have one. Nothing stops it from overheating.


Thanks to everyone who helped to get the new sandpit for my stepdaughter! :heart::slightly_smiling_face:

Currently I am trying to get a build done on latest source with June security patch level. Sadly Tuna and Espresso3g failed and need to find the root of problem…

I’ll post a build once they compiled :slight_smile:


Wow !
felicitation, it is not a little plastic shit…
and it is “cats proof”…

Got the build done.


Removed packages on espresso3g (else system.img is out of space):

  • PdfViewer
  • Terminal


Removed packages on espressowifi (wifi only device)

  • ESmsSync


@piero yeah, but the cheapest wooden sandpit. But It’s enough for our use :slight_smile: A Plastic one wouldn’t last long :wink: thanks again!

1 Like

You rock! Thanks Andi. Will install it today, I have to take backup for stuff tho

1 Like

Thank you very much. I’ve just installed and worked flawless, fast and no lag. The UI is very beautiful. I’m new here and have one question, how do I get the Google Play Store in this? I searched the app I wanted on the store that came with but there isn’t. Also I tryied to download Chrome on that store but it crashes before beggining to download. Thanks for any help.

This is a goolag free OS. No goolag store or any other spying goolag apps available.
Installing goolag apps on this OS is like putting alcohol in an alcohol free beer.

If you need apps, you can use f-droid for FOSS apps and Aurora from F-droid for spying apps from goolag store

1 Like

Thank you very much, sir !!
You rock !!

1 Like

Very nice sandbox. We didn’t have a top on ours when I was little, we had St. Bernards, no kitties. I can lend you a Labrador Retriever until you can get a dog.:grin:
I am amazed at how well the build runs. Much better than I expected. And thanks for fixing the rotation problem. Launcher seems ok so far.
I don’t have wifi at the pool, so it will be a while until I get all my stuff going and thoroughly abused at work.
Awesome job!

1 Like

Just installed, thanks @Android-Andi!

Amazed by the modern looks and pretty smooth operation. Will keep adding apps & report back in some time.

1 Like

Still very happy! Using (F-Droid) OpenLauncher instead of Bliss, gives me an app drawer.

What a joy to be able to run several modern apps that I couldn’t even install on stock 4.4.

The experience is not lightning fast, but hey, that’s the stone-age hardware’s fault, not /e/'s.

Battery life is definitely better than on 4.4 - probably due to better power saving in 7.1.

This is great. Thanks @Android-Andi

3 months later,
espresso3g : 167 downloads
espressowifi : 203 downloads

1 Like

Hi all,
I tried to install the latest build (0.9-n-20200618-1754) with USB-OTG on my P3110 (Tab 2 wifi) but I face an error when installing the zip on TWRP :
Patching system image unconditionally
E1001: Failed to update system image
Updater process ended with ERROR: 7
Error installing zip file ‘/usb-otg/’
Updating partition details…
… done

Any idea ?

I answer myself : did 2 things.

  1. update TWRP to the latest release 3.1.1
  2. after formatting /data, reboot into recovery to be able to access /data (sometime useful to read the screen, even if this is a successful message :wink: )

/e/ is booting now !

1 Like

Hi all,

I have a difference between 2 Tab 2 7.0 :

  • on one of these, /e/ is running fast and is working well
  • on the other one, /e/ is unusable, very slow and sometimes completely frozen

I tried third times to wipe the tab et reinstall it (no error) but I have the same issue… Maybe one indication : I have exactly the same thing with a lineageos 14.1 rom, but everything is going well with CyanogenMod 13 (lineageos 13.0 rom has a wifi bug).
Anybody has an idea ?