Samsung Galaxy Tab2 espressowifi (two models 7 & 10)

After further testing and (clean) reflashing the ROM, I came to the conclusion that rooting status has nothing to do : sluggishness is random. Sometimes the tablet is fine (rarely), sometimes it’s slow (often), sometimes is sluggish as hell (often)… but rooting makes it much worse and frequent.

Also, only the UI seems unresponsive : for instance, network operations seem to behave at normal, if modest, speed.

I confirm getting the same issue with a very slow device, nearly unresponsive. And what I don’t understand is that the Tab2 which was fluent became very slow just after a few days without installaing any additionnal application. And even a complete reflash did not solve the issue this time.
@breversa : this has effectively nothing to do with root access.

1 Like

Could you please help us @itsclarence ? @petefoth ?

1 Like

Sorry - it’s out of my league I’m afraid. The latest official LineageOS build I can find is Android 6 ‘marshmallow’, so there would - I guess - have to be some work getting it to build for android 7 / Nougat.

I have no idea how to go about doing that, and I don’t really have the time (or the motivation to be honest) to find out what would be involved. And I’m quite busy at the moment with devices which may or may not get official builds sometime soon (soon-ish, maybe :wink: )

It would be a great project for someone who owns one of these devices and wants to find a[out abut building ROMs :wink:


EDIT: OK, I’ve found the lineage repo which is CM-14 which I think is nougat. There also appear to be a Muppets repo with the proprietary blobs in.

So all a potential builder would need to do is cobble together a manifest - @Android-Andi might be able to help with that - persuade it to build, and then debug it when it doesn’t work :slight_smile:

Like I said, an interesting project for someone, but not for me. If anyone does pick it up, I’m happy to help test anything that gets built. I own a 7" version, though I haven’t touched it since I installed @Android-Andi’s last build.


Sorry folks…its out of my league also.
I’ve tried it, but making this nougat rom requires a very different build environment than I’m used to now.

@petefoth @itsclarence Thank you guys for taking the time to respond. I hope that one day, someone will be able to resume your work. :slight_smile:

1 Like


I have the same performance issue here. Just flashed recovery version “espresso-common_TWRP_3.3.0-2” recommended below and the “e-0.9-n-20200618-1754-UNOFFICIAL-espressowifi”, but the performance is very very slow and sometimes frozen as well.

Before that I was using Lineage OS Android 4.4 and the performance was normal.

I wonder what could it be that causes this performance penalty on /e/ OS e-0.9-n-20200618. Could it be the NAND storage with lots of dead cells? Could it be a rogue background process hitting the storage/CPU?

This severe slowness remembers me when on a PC Windows is indexing/hitting the HD hard on the background and everything else slows to a crawl…

Is there any “show resource utilization” option on the Developer Options screen or something like that?

I am really intrigued that some people experience a snappy performance on the same hardware with the same ROM…

I used to use but it’s no longer maintained, and I haven’t tried to use it for that device yet.

So we want to build /e/ again? There are proper nougat sources and a 3.4 kernel on well are there some porting docs?

1 Like

Yes, they probably did their annual commit session

3 months later,
espresso3g : 167 downloads
espressowifi : 203 downloads

12 months later,
espresso3g : 1095 downloads
espressowifi : 1326 downloads

1 Like

FWIW, here’s a logcat I managed to capture right now.
The adb session died on its own at the end of the log.

1 Like

[final edit Fri 7 Jan 20:41:42 GMT 2022 ] Build abandoned. Out of date stuff removed. See next post

1 Like

I have spent quite a lot of time this week trying and failing to make some up-to-date builds for this device. I had thought about leaving my device on @Android-Andi’s latest unofficial 0.9-nougat build, which works pretty well, but the temptation to try and make something a bit more up-to-date was too great, and the weather here has been too bad to be doing much outside, so…

First I tried a CM-14.1 build of Lineageos4microg, using Docker, but I could not get it to build.

Then I tried a v0.19-nougat build of /e/OS, building the traditional way with (lunch, mka bacon, etc). I eventually managed to get it to build, by removing some of the built-in apps, but the build will not run: it black screens, after showing the splash screen.

I have decided that life is too short to spend more time getting /e/OS to run on a device that is just a bit too old, small and feeble to really do it justice.

My device is now running with a ‘D-I-Y’ lineage4microg, plus sync to /e/'s cloud services, created as follows

  • @Android-Andi’s LineageOS 14.1 ROM from here

  • using the Nanodroid stable zip files from here

    • patched to allow signature spoofing using

    • F-droid, Privileged Extension, Aurora Store and Aurora Services installed using then updated via F-Droid

    • MicroG installed using , updated by adding and enabling the MicroG repo in F-Droid

  • Apps installed from F-Droid - DAVx5, Fennec, NextCloud, NextCloud Notes, K-9 Mail, Open Launcher

All of that gives me something aproaching /e/ OS, but with a sensible launcher, MicroG EN Framework working by default, up-to-date email and notes apps, and mature, trusted app stores. It’s not perfect, and it’s a bit laggy, but it will do for casual use.

I ‘installed’ some other Apps by copying from my daily driver (Xperia XZ1 Compact, running e-0.20 Custom build) using Android Backup and Restore Tools - WhatsApp, Facebook Messenger, and a couple of other apps that ‘just work’ without my having to enter account details again :slight_smile:

So that’s it for me building trying to build for this device: it’s been fun and frustrating in about equal measures, but I’ve learned quite a bit in the process. Now to get ready for testing v0.21 releases :wink:

Might be the combination of repos you’ve used.
On my personal builds I’ve used some combination of lineageos sources and sources from unlegacy-android. Those UA parts depend on some other changes in the frameworks part of android, kernel and hardware repo and blobs.“omap-ddk-1.14”+(status:open%20OR%20status:merged)

1 Like

Thanks. It looks like building /e/OS and/or LOS4microg is solvable, and would be an interesting problem to solve, but I think I will focus my efforts on more recent, more powerful devices. My espressowifi device is now working well enough for me, with the setup described above :slight_smile:

2 years later :
espresso3g : 2550 downloads
espressowifi : 2860 downloads

1 Like

1 Like

How to use both /e/OS and Linux PostMarketOS Community pre-built image on Galaxy Tab 2

Note20x20 install instructions for Phosh and XFCE4 images

works running from a SD card

as explained in Installation - Flashing - From SD Card Our device can boot a SD card, USB stick or other external storage.


preparation in a way to easily switch between /e/OS and PostmarketOS

from your actual Android_OS install file (AP_Stock_Samsung_Firmware.tar.md5 or, extract the boot.img and copy it to your TWRP folder in internal storage (/sdcard/TWRP)

Download the pmOS pre-built image

from the download page

insert a MicroSDcard into your Computer

and find its name by running

$ lsblk

make sure it is the right one as you will overwrite everything on it. Use a path without partition number at the end,

such as /dev/mmcblk0, or /dev/sdd

decompress the downloaded file and write it to your MicroSDcard :

$ xz --decompress --stdout /path-to-pmos-samsung-espresso10.img.xz | sudo dd of=/dev/name-of-your-SDcard bs=4M status=progress

Wait until the command completes and eject the SD card.

If you are on Windows, see here.

insert the MicroSDcard into your device, and boot it into TWRP

using the mount feature, unselect all /partitions except “MicroSDcard”,

using the install feature, switch to “install image” rather than “install ZIP”

navigate to the “/external_sd/boot.img”, and flash it to the /boot partition

reboot system

The rootfs image will boot right into postmarketOS. You are done with installing postmarketOS, congratulations!

default login is user and password is 147147

to restore your /e/Android_OS

boot the device into TWRP mode,

and simply using the install feature, switch to “install image” rather than “install ZIP”

navigate to the previously stored “/sdcard/TWRP/boot.img”, and flash it to the /boot partition

to restore your PostmarketOS

boot the device into TWRP mode,

and simply using the install feature, switch to “install image” rather than “install ZIP”

navigate to the “/external_sd/boot.img”, and flash it to the /boot partition


Linux PostMarketOS on samsung Tab2 7.0" all variants (espresso7)
Linux PostMarketOS on samsung Tab2 10.1" all variants (espresso10)


the “dual-boot” should work also for others devices in the community list :

1 Like