Samsung Galaxy Tab2 espressowifi (two models 7 & 10)

Alrighty it worked, thank you all for helping and thanks Andi for building it!
It feels really snappy :smiley: will try with some apps installed
Camera is broken and keyboard appears when i remove app from recents :?
Nevertheless I hope someone continues this (or maybe Oreo Go considering normal Oreo will be too heavy for 1 gig RAM)

Edit - Cant install app from Apps nor can download apks…

Have you allowed installations from unknown sources search « unknown sources » in >settings ?

Yes, ofc!
When I try to install from “Apps” it crashes adn downloading apk just fails

Yes of course you have checked the sum of the Android-Andi’s build zip ?

Downloaded from here

a downloaded file could have micro-failure or corruption
i have read some users have re-downloaded the .zip file and fixed their problem

I cannot download the files like when i click download on the Apps it crashes and in browser it says network failure (I am connected to wifi and all websites open normally)

But i will try redownloading and flashing again :smiley:

While I’m still going on in using /e/ on my old tablet and being pretty happy with it, today I discovered the GPS isn’t working, at least with the following app: Here WeGo.
Is there any alternative way to check if this is App related?
Thanks!

Well it is pretty good, but I would like to try oreo and for that i will try to build oreo myself, is there a place i can ask if i get stuck?

Hello ! First of all, a huge THANK YOU for bringing /e/ to these old devices ! :smiley:

However, I notice the same massive slugginesh/reactivity issues (to the point of unusableness) as @Cys (Samsung Galaxy Tab2 espressowifi (two models 7 & 10)) once this devices (P3110) is rooted, be it with either Magisk or https://mirrorbits.lineageos.org/su/addonsu-14.1-arm-signed.zip ?

I’m getting loads of “Choreographer: Skipped XXX frames! The application may be doing too much work on its main thread.” (with XXX regularly ranging in the 300-range) in logcat.

After further testing and (clean) reflashing the ROM, I came to the conclusion that rooting status has nothing to do : sluggishness is random. Sometimes the tablet is fine (rarely), sometimes it’s slow (often), sometimes is sluggish as hell (often)… but rooting makes it much worse and frequent.

Also, only the UI seems unresponsive : for instance, network operations seem to behave at normal, if modest, speed.

I confirm getting the same issue with a very slow device, nearly unresponsive. And what I don’t understand is that the Tab2 which was fluent became very slow just after a few days without installaing any additionnal application. And even a complete reflash did not solve the issue this time.
@breversa : this has effectively nothing to do with root access.

1 Like

Could you please help us @itsclarence ? @petefoth ?

1 Like

Sorry - it’s out of my league I’m afraid. The latest official LineageOS build I can find is Android 6 ‘marshmallow’, so there would - I guess - have to be some work getting it to build for android 7 / Nougat.

I have no idea how to go about doing that, and I don’t really have the time (or the motivation to be honest) to find out what would be involved. And I’m quite busy at the moment with devices which may or may not get official builds sometime soon (soon-ish, maybe :wink: )

It would be a great project for someone who owns one of these devices and wants to find a[out abut building ROMs :wink:

Sorry!

EDIT: OK, I’ve found the lineage repo which is CM-14 which I think is nougat. There also appear to be a Muppets repo with the proprietary blobs in.

So all a potential builder would need to do is cobble together a manifest - @Android-Andi might be able to help with that - persuade it to build, and then debug it when it doesn’t work :slight_smile:

Like I said, an interesting project for someone, but not for me. If anyone does pick it up, I’m happy to help test anything that gets built. I own a 7" version, though I haven’t touched it since I installed @Android-Andi’s last build.

2 Likes

Sorry folks…its out of my league also.
I’ve tried it, but making this nougat rom requires a very different build environment than I’m used to now.

@petefoth @itsclarence Thank you guys for taking the time to respond. I hope that one day, someone will be able to resume your work. :slight_smile:

1 Like

Hi,

I have the same performance issue here. Just flashed recovery version “espresso-common_TWRP_3.3.0-2” recommended below and the “e-0.9-n-20200618-1754-UNOFFICIAL-espressowifi”, but the performance is very very slow and sometimes frozen as well.

Before that I was using Lineage OS Android 4.4 and the performance was normal.

I wonder what could it be that causes this performance penalty on /e/ OS e-0.9-n-20200618. Could it be the NAND storage with lots of dead cells? Could it be a rogue background process hitting the storage/CPU?

This severe slowness remembers me when on a PC Windows is indexing/hitting the HD hard on the background and everything else slows to a crawl…

Is there any “show resource utilization” option on the Developer Options screen or something like that?

I am really intrigued that some people experience a snappy performance on the same hardware with the same ROM…

I used to use https://f-droid.org/packages/com.eolwral.osmonitor/ but it’s no longer maintained, and I haven’t tried to use it for that device yet.

So we want to build /e/ again? There are proper nougat sources and a 3.4 kernel on github.com/Unlegacy-Android/ well are there some porting docs?

1 Like