Samsung S3 - No SIM Detected

Hi there. I know this has been raised before, but I feel like I’ve tried everything I found, but without a solution.

I’ve tried going back to the stock ROM, and confirmed it was getting a signal and detecting the SIM. I made a backup of the EFS, which I then restored in TWRP after re-installing /e/.

I’ve turned off profiles, as I read that fixed it for some people.

Rebooted after each attempt, but it’s still not detecting there’s a SIM inserted (SIM is confirmed working in other devices). There’s a Baseband and IMEI number showing in phone info.

Anyone got any other suggestions? Thanks!

1 Like

I had the same problem with my Galaxy s4 mini lte
The card worked on other phones, rebooting did not help.
But all the time I had the airplane mode turned on I thought it would not change because the card is not detected anyway. After turned off airplane mode the card is detected again, even if you turn it on again.
I hope you fix this too.

Hi, on galaxy a5 2017 there are different bootloaders/modem for different android version, for example if you are on oreao and flash /e/ which is nougat version then sim doesn’t work… if you flash nougat BL/modem then it works… so maybe you can try to flash stock firmware which is the same version like /e/ and then flash /e/ … I’m not sure if that is a case on yours S3… but I had similar case on A5… so maybe that’s it :slight_smile: