Samsung S7 - Herolte and V1.6


i have a Samsung S7 and installed the 1.6 Version successfully on the device.
As far as i can see everything is fine accept the Wifi Connecton.

I like to use my phone to stream Radio which is working as long as the screen is on.
I have tried a lot of settings:
Battery optimisation off
Unlimited Data on
Energy save set to max performance
Reset Network setting and connect again
Remove the device from the router and reconnect
Updated the Router Firmware
Tested another Radioapp (which improved the situation, but not resolved it)

Nothing helps. After the screen goes off it plays some minutes before the Wifi cuts off and then it sometimes only reconnect if the wifi Menu will be opened.
In some cases the Bluetooth connection will be dropped as well if the wifi cuts off.

Before installing e the phone was on Samsungs official Rom , hut i think not on the latest version does anybody have an idea or am i the only one with S7 having this issues ?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What app are you using for radio streaming?
Have you tried a different one and does the problem persist?
Have you updated to 1.7 and does the problem persist?
I just tried streaming from “ARD Mediathek”-app and I do not have such issues with wifi cut off in screen-off-mode on my S7 (on 1.7).

Hi, i have updated to 1.7 now, but it is still a problem.
I tried transistor , openradio and newpipe. I tried transistor and openradio with mobile data and there is also no problem.
The strange thing is, that the time when WIFI cuts out is not always the same. Sometimes it works for 10 Minutes, sometimes for 30 Minutes.
Usually i am listening via my bluetooth headset and interestingly sometimes the headset gets disconnected together with wifi cutting off. Then Wifi does only reconnect after i turn it of an on again.

I have updated my Fritzbox 7490 to the latest firmware, but that didnt help either.

Thanks for reading.

Not sure then if my use scenario qualifies as test case for your issue at all. I rarely listen long enough with screen in sleep mode without waking up the screen by interfering in one way or the other.

(You might try with screen setting ON as long as possible (max 30 min is possible in my settings) but of course that’s a battery consuming scenario and it bears the risk that touching the screen meanwhile will interrupt or change anything in unwanted ways…it sounds like bad idea while I type it :grin: … maybe OK only for the testcase)
Have you searched eOS’s gitlab for any related issues?

Update for someone with the same issue:

Now i am on Dev Version 1.81 and the issue is still the same.

But i think i found a work around that works for me:

  1. Activate developer options in the phone and USB debugging on the phone
  2. connect the phone via USB with the computer
  3. Open a Terminal
  4. Open ADB-Shell (should be installed first)
  5. Enter the following command: “settings put global wifi_suspend_optimizations_enabled 0”

Now the WIFI seems stable, also with screen off.

I have reported this to gitlab as well. May be somebody takes care of this.

best regards

1 Like