Samsung S7 stuck in boot after changing screen

Flashing is throwing a file in the phone root. Installing is executing a file.

LISTEN, download the .img.tar file, not the .img, for TWRP or you won’t be able to put it in ODIN

If I understand correctly, we try the ADB method on a Windows computer.
I have downloaded the ADB exe file and run it, it begins with asking if I want to intall ADB and fastboot Y/N, what do I do?

I also downloaded the img.tar file, the one on the top of the list.

The process should be like your description of the Odin install. Phone connected via USB to computer. Phone may need a special boot, “download mode”. Not sure of battery status, plugged in a charger and it starts automatically into recovery mode. I’ll try your volume down+home+power trick - did that and the only thing that happens is a ring with a flash appears on black screen.

For ADB, just accept everything as it is important, especially the Google pilot.
For the .img.tar file, that’s ok.
Can you take a photo of the screen with a ring please ? That could be useful, as I don’t know what it is… Normally, if you do that trick, that should boot on download mode…

The screen with a ring disappeared when I tried again your button trick, it now starts up to the dancing e symbol screen (bland with a dot dancing under e), which it does for 20 minutes or so until I see the recovery screen. Now waiting for the dance to end…

Getting to Download mode is explained in more detail here Know your hardware - SamsungAccess Download mode

When you see the bouncing e you have simply arrived at your failed system – so please try again for Download mode so you learn to have full control of the device first.

I have tried probably 20 times, always after dancing e end up at recovery screen.

I’ll still ask you to send me a photo of that screen if you can.
You are supposed to enter the download mode when pressing the button trick… I would be very surprise if it was deleted.

The circle with flash disappeared. Maybe it was because of low battery…?
Now I have recovery mode. Shall I shut down and try the download reboot trick again?

You have to button trick before the e logo appears. You shutdown the phone, and when it’s shutdown, volume down+home and THEN press the power button, but all at the same time. I don’t know if you understand…

The circle appears when the phone is shutdown and charging. Try to shut it down and then do as I told you.

Sure, I understand. I tried that many times, the reboot trick. I did it before our conversation here.
But shit, now we have another problem, I can’t shut it down, it just reboots… In recovery mode, I go to advanced then shut down, then it reboots…
:crazy_face: This is crazy, so many problems…

Since there is an option Update from ADB in recovery mode, can’t that be used?

sure, this could be used. have you set your computer ith the ADB (Android Debug Bridge) suite/software ?

I’ve been reading this sub for several days.
for your information heimdall is the equivalent of Odin but for linux systems ^^

Welcome Didou to this growing sub…
I am ready to install ADB on my Windows 11 computer, just waited to see if it was necessary.
Ok, I will go ahead.

I came so far as running ADB and typing adb devices in the command prompt.
Then I am not sure what to do. It says daemon started successfully in the prompt. Then nothing.
Phone connected via USB.
I then tried to chose ADB sideload on the phone, but it is unclickable.
Not sure what to do now.

Unclickable ? Then try with the volume down and up to choose and the power button to click… Ye it’s crazy the numbers of problems there are each time…
Normally, when you have selected the ADB sideload, your phone is waiting for the update. Then you throw the file from the computer to the phone using an ADB prompt.
You need to download the /e/OS rom firstly: you can find it here, as @piero said:
When you have downloaded the file, you throw it using the ./adb sideload <> prompt. You might want to run it as an admin. When I say <>, this mean the path, like C:\Users\Admin\Downloads\

When chosing ADB sideload on the phone, will it show something, like a screen? Maybe I don’t need to click it, maybe it is just waiting for the update?
Can not change anything with the volume up or down…

Now first I tried to do what you say “throw the file from the computer to the phone”. Not sure what the phone is doing, but maybe it is waiting for something, in any case I wanted to see if I can understand the process on the computer. Seems I can’t… I have the /e/OS on a USB stick, file path E:
You run that command on the command prompt? I tried it and it says syntax error.
Then what do you use ADB for? When running ADB it asks questions, like install drivers. I have no idea what it is doing…
I think this is never gonna work and I am up over my head in this, but thanks for your attempts to help.

Just copy the /e ROM on a SD card, on your computer and then insert it into your S7, choose install from file in you recovery. It’s all very intuitive that way.

make-nz, I tried that (SD card method). That was the first thing I did. Does not work. If it was that easy…
I think this phone is specially difficult. After all, last time, I tried to three days and failed. But another guy actually managed to do it, he is pro, so it is doable though.

Maybe I got the ADB process wrong? I actually don’t understand how to do VinK’s commands above. That is probably vital. Let’s try again with that, doing it right, and if that does not work maybe we have to consider that this is impossible and give up.

Oh ye ! You should have on the bottom screen something like “waiting for update”.
If you have your rom on a USB key, that should do something like adb sideload E:\path\to\your\file\ If it doesn’t work, try just to put the file name like adb sideload <>