Samsung s7 updates

There certainly is a minefield of information out there. I suggest you check the weekly #e-smartphone-operating-system:development-updates .

The past two or three weeks have contained news of the progress. S7 has featured a bit. OTA version Upgrade together with the brand new Advanced privacy can be a leap which you might choose to avoid until you feel well informed, especially for an “older phone” like the S7.

The options to go back if it does not turn out well for you may be limited. I propose you treat this enterprise with the caution of a “test” – you can always leave the test to others, read of the results and proceed in your own time.

Hi Aibd,
Thank You, that´s a valuable advice I wish I had read before :slight_smile:
Especially the limited way back

But anyway … yesterday I was curious and decided to give it a courageous try to go for the 1,0.
Not sure if I´d do it again, but worse things happen at sea… so here´s my first impression of 1,0 on S7:

In general the options to grant or deny very specific rights to apps (like work in the background, start with system boot etc.) seem to be more limited now, some settings are hidden in the Developer Mode now, some are not available anymore.
The settings-area looks more “modern” maybe for the price of being more nested (?), not sure if I like it though, for sure I´ll need some time to get used to it and find my ways…

The advanced privacy is not of much help in my use scenario because blokada-app does a much better job already (for me) and I could not find a switch to stop the advanced privacy from working in the background yet.

If I had put a bit more thought into my action I had better backed up the content of apps that I had to reinstall afterwards because they were not functioning anymore. Now they do but I lost some stuff… could be worse - but could have been avoided easily :roll_eyes::

  • signal-app -I should have backed it up before (I lost all messages and media), the upgrade to 1,0 is seen as “system-reset” by signal as it seems, to me that´s plausible … signal-users better be prepared! :slight_smile:
  • for medilog-app I had a not so old backup available I could use
  • for covpass-app it was easy…

All in all up to now it looks OK and useable … due to the good work and support of beta-testers I guess - so thank you in that direction as well!

My strong hope is that power consumption will not raise much

Can you rephrase that, please? I don’t understand

Good point cedricoola, my description is certainly not the proper technical way to describe it and might be technically wrong or misleading.
Since I do not know what really happened in the background I´ll describe my observations in more detail:

  • all of my previous systemupdates worked flawlessly regarding the existing signal-installation (and all other apps) and all these updates happened within Android 7 (to my best knowledge and memory)

  • Updating to 1,0 meant a change from Android 7 to 10 - that´s how I came to describe (or understand) this as a form of system-reset

  • After the system-update I couldn´t start signal anymore, system restarts did not help. I could start signal again only after re-installing it - which meant losing messages and media. After installation and registration of signal I found my avatar still existing and I had automatically moved into all groups I was in before.

  • Meanwhile I read through the support pages of signal and came across this:
    The info I refer to goes along the lines of: “…Message restoration or account transfers are not currently supported, if you: … cleared your phone. …”
    Somehow in my head that linked to the change from Android 7 to 10 and I thought that update might equal clearing of the phone and that somehow made sense to me - but now I am not that sure anymore :slight_smile: maybe a bit of a twisted conclusion (?)
    I should least have written clearing the phone instead of system reset

hope that makes some sense

anyway: If I had backed up my signal before systemupdate I could have restored it after re-installation.

I see. Thanks for explaining!

I just updated my Samsung Galaxy S7 to version /E/OS 1.0-2022052618885 after I got a message that a new update was due. Didn’t know it was from adroid 7 to android 10 :thinking:. I have the same problem as obacht described. Signal wouldn’t start and I had to reinstall it. Now it works, and all the groups were restored but the conversations are empty. I did make backups but when I tried to use these I have to produce a backup password that is not the same as the verification password and I have never heard of a password when making the backups :hot_face:. I still have the conversations on my laptop and pc, but is there any way to get them back om my phone?

By the way, so far I’m not very happy with the other changes, but maybe I have to get used to the different look and feel. Maybe the advanced privacy app built in is a good thing, but I don’t know yet.


I updated 3 days ago.
I had some problems with evernote (data lost) but it maybe comes from evernote.

Since today, I have trouble with my SD card : the system ask me to format it. I tried with an other sdcard and the problem is still there.

I reseted the phont and still have the problem.

It may me a coincidence but it’s strange, no ?

What can I do ?

The sudden jump of Android 7 to 10, seems to be an issue for Signal and its backups. I would check for an issue for that on Gitlab, if not found, Report an issue.

Edit: is here already :blush: S7/S7+ upgrade related issue

Regarding SD card reformat, in another device I have received reminders but I am able to just ignore them.

If you device was originally installed as “extended internal storage”, this is a different case. (I can give a workaround, if required.)

I feel SD cards kept as external storage is best.

In my case the SD card has no issues so far.

But there´s another issue that also signal suffers from:

Some apps do not get access to mobile data even though all accessible permissions are granted.
signal suffers from that as well as e.g. wetter online or meteoblue.
They only get internet access with wifi being active.
signal even states “background connection active” (or the like, not sure about the correct wording in English) but does neither receive or send messages until wifi is switched on and available…

Other apps like fairEmail or browser have no problems at all - with exactly the same settings in terms of network permissions like e.g. signal

edit: I wonder if there´s a more appropriate place (or section or whatever) in this forum for such feedback on 1,0 than this thread - I mean w/o going so far as going to gitlab :slight_smile: … because that´s a different world for me. It´s simply that i´d be happy to provide feedback on 1,0 were it makes most sense to place it (outside gitlab…)

@obacht it is always fine to open a topic on any subject. Just make the title reflect the focus of your topic, whatever #hashtag you give it, it can get moved! Don’t give that a second thought!

Edit. #v1.0 might be quite useful, should anyone start to use it.

1 Like

Thank You for your encouragement.

the story goes on here: Mobile data issue v1.0 on S7

1 Like

I have been working with the version 1.0-2022052618885 of /E/OS om my S7 now for a week, but I find many small glitches. For example, since I updated, many people find hearing themselves twice when I call them. When they call back, most of the times the echo is gone, but not always. I have no trouble with hearing the person on the other side.
Another thing is that the phone screen turns very dark sometimes without an appearant reason.
Signal sometimes stops receiving messages and this can only be helped by restarting the phone.
Some apps (like Magister, an app for Dutch schools) can’t find my account anymore, even after reïnstalling, which means that they are useless.
Sometimes I can’t pick up when I’m receiving a call.
All in all mostly small nuisances, but altogether rather irritating. I hope there will be an update soon that resolves these problems.

About the OTA update:

  1. use TWRP to install e-1.0-q-20220527189323-dev-herolte. Preferably doing a clean install ? Or is it safe to go with a dirty install ?
    Do we have to re-install TWRP afterwards ? How ?

  2. use the easy-installer ?


TWRP install should be fine.

With change of Android version you cannot dirty flash, you must wipe data (so a good independent backup first!).

I think I would check how old TWRP version is, and consider upgrading first to be on the safe side – I am unsure, but an older TWRP might throw a wobbly at Android 10.

1 Like

There is no clear migration description, at least for for those who are still on oreo-dev 0.20-o-2021 & TWRP 3.2.3-0 on galaxy S7.
Since OTA does not work with this eOS revision, we have to flash.
But I don’t see up to date documentation.
For the time being, I just tried to update TWRP to have it compatible with Q which I hope to install soon. But version 3.6.2_9-0 can’t browse the internal storage. So I used heimdall to back down.
1- can we upgrade from Oreo 8.1 to Q using TWRP 3.2.3-0 to flash ?
(with some wiping I guess)
2- Is it a solution to use the easy-installer ? But which version of eOS will be installed then ?
Thanks to clarify

Today, I decided to go for the easy-installer. The installer guides you trough the process very efficiently, step by step. Then the installation takes 15mn and you get a galaxy S7 running Android 10.

  • All Pictures, Notes, Contacts are back automatically when you setup your account on the phone.
  • TWRP is gone after the Q installation: replaced by e-recovery.

I am now going to test and see if everything works.
For the time being, I am very happy with this solution.
Talk to you later

Ive updated to last update of e-os , the way its done is a bit wrong cause there’s no rollback option. i was sure everything was tested and i am very disappointed to find out that since the new update briar wont work and also molly ( - a secure version of signal .

I would appriciate if you supply me with means to rollback to the previous version from october - otherwise i will need to reinstall from scratch and that is very painful.

im considering moving to other os… its one thing to publish some version that youre not sure about , its another thing to supply through the updater, screwing the apps runing and having no option to rollback.

Did you do a clean install ? If not, did you try to clean the cache of these apps ?

ive tried clearing cache…doesnt work. i can try clean install but it means i might lose access to my messages. that’s a really bad exampe of how to an update to os.
i need to lose all my messages and then the “update” works? it doesnt work. perioud. previous updates didnt do such a huge mess. never.

also session wont work (

Problems I have found so far after installing Q with the easy-installer:

  • my newest contacts are lost (yet, they were synced to ecloud)
  • still the annoying “echo in call with loudspeaker” problem. It is there since the nougat version. See Galaxy S7 echo during calls with speaker - #12 by Cricoo
  • Mail accounts have no more an associated color. That was an handy feature.
  • App lounge crashes sometimes. To clean its cache makes it run again.