Samsung S9 - Heimdall detecting fail

Hi, i’m trying to install /e/ on a Samsung Galaxy S9.
I’ve read all the instruction but i’m stuck at the beginning with Heimdall.

fab2b@fab-debian:~$ heimdall print-pit --verbose
Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...

            length: 18
      device class: 2
               S/N: 0
           VID:PID: 04E8:685D
         bcdDevice: 021B
   iMan:iProd:iSer: 1:2:0
          nb confs: 1

interface[0].altsetting[0]: num endpoints = 1
   Class.SubClass.Protocol: 02.02.01
       endpoint[0].address: 83
           max packet size: 0010
          polling interval: 09

interface[1].altsetting[0]: num endpoints = 2
   Class.SubClass.Protocol: 0A.00.00
       endpoint[0].address: 81
           max packet size: 0200
          polling interval: 00
       endpoint[1].address: 02
           max packet size: 0200
          polling interval: 00
Claiming interface...
Setting up interface...
libusb: error [op_set_interface] setintf failed error -1 errno 71
ERROR: Setting up interface failed!
Releasing device interface...

At first i was using the old version of Heimdall (1.4.0) and thinking it was the problem, apparently it’s not. I’m not an advanced user, so i don’t understand where the problem is now.
I’m on Debian Buster by the way, if it’s help to solve my problem. I’ve compiled myself heimdall with the source code of the git author. ( In your Heimdall documention here, your source code link is obsolete.)

I’m not sure about this either but from looking at the error “libusb: error [op_set_interface] setintf failed error -1 errno 71” I assume that the phone did not even send a response to any of your computer’s requests or there was an error with setting up the interface. So the error happened at a very early stage before flashing could even happen.

Is the bootloader of your phone unlocked (OEM Unlock)?
Do you have usb debugging enabled?
When are you connecting your phone to the computer? You have to switch to download mode before plugging your phone into the computer.
Also try to disconnecting other USB devices which could possibly interfere (not keyboards and mouse but media devices) with heimdall.

Make sure your computer has working SDK Platform Tools for Linux. Do commands such as adb devices and adb shell work properly?

Thank you for your concern @exyna and @archje, it was more simple than that … It needed to do it with ‘sudo’, other that it return errors … Sorry, just my mistake :roll_eyes:

1 Like

Ah, sometimes it’s just the simple things :slight_smile:
That idea would’ve never come to my mind as heimdall works without sudo for me

well, i didn’t thougt it needed to but, just in case, i tried and it succeed so … maybe it’s just needed because i build it from source code ? or because i run it from Debian, i don’t know.
By the way i follow step for installing /e/ now, but i didn’t find the “ADB Sideload” on the device side, wich the tutorial ask for, any idea where is that ?

Can you tell me please what PDA code (build version) your current StockROM firmware has? You can find this information in your S9 via > Settings > About phone > Software Information > Build number …

Install /e/ on a Samsung Galaxy S9 - “starlte”

  1. On the device, go into Advanced > ADB Sideload, then swipe to begin sideload

In TWRP Recovery this command is provided.

What is ADB Sideload and how can I use it?

Thank you @archje, your reply was helpful. In fact, there’s a mistake in the steps order in the Documentation :
Install /e/ on a Samsung Galaxy S9 - “starlte”
I was stuck in the “patch device” step, this might be next to the TWRP installation…
When you show me how TWRP looks like, it appears to me that there’s something wrong so i tried to install TWRP 1st. When it done, i was able too patch and follow the others instructions and finally complete the installation of /e/ on my device.
Thank you for your time, all of you !

I’m pleased for you @Fab2B. Welcome to the /e/ club.

@Fab2B I’m curios to that information as well since I would also like to install /e/ on my S9 however there seem to be some problems with new S9 devices. See Help installing /e/ on Galaxy S9

Sorry @0x7C0, i wasn’t home in while du to work. I’m not sure i understand what info you want… on /e/ i didn’t find what’s PDA is …
But there’s the info i can share, hope it help :

  • Device model :

  • Platform :

  • Android vers :

  • API LIneageOS :

  • Baseband version :

  • Kernel version :

1 Like