Samsung S9 not supported?


While running the Easy Installer (on Linux) I received the following error

Which surprises me because this is the whole reason I bought this phone, so I could easily install /e/.

Please let me know what I could do to fix this! I’ve really been looking forward to using the /e/ OS.


Have you also updated your phone to Android 10?

Why should be updated to android 10 when the easy installer is installing Oreo 8.1 in the phone?

Because “latest steack firmware available” is recommended, butternut “android.10 firmware is needed”.

That’s right for the moment.


If you are not in disposition to wait for about 3 weeks ( or more )
to use the stable /e/android.10.Q,
you can manually install the dev /e/android.10.Q
! ! Lets do that ! !

1 Like

Yes, phone is on latest stock Android 10.

Thank you for your quick response @piero.

I got as far as Unlocking the Bootloader.

The device rebooted but I didn’t need to setup device or re-enable Developer options.
No factory reset seems to have occurred. Do you think the bootloader is already unlocked?

Screenshot from 2021-05-27 09-17-27
Also, how do I install the patch?

I can’t find Advanced > ADB Sideload,

Thank you again for your help!

The patch should be that .zip file referenced when using the adb sideload command on your computer. The “Advanced > ADB Side load.” Is a command in your recovery (/e/ recovery or Team Win Recovery Project “TWRP”). Basically, you use the Linux terminal to send the zipfile to your phone ("side load"ing the zip file) after your phone has been set to accept the file while in recovery mode. From what I gather you are not looking at the right thread for a fresh e install on a S9 though. See below.

Edit: > HERE is a link for how to do all steps on a S9 specifically. Be sure the /e/ ROM you download is for Android Q/10 as it has to match the version of Android on your stock ROM (you mentioned your new phone is on Android 10/Q currently).

Edit: In the previous paragraph you will find the /e/ ROM for Android 10/Q listed as " * /e/OS build : dev" NOT “Stable” :point_left: this is for phones currently running Android 8/“Oreo”

If I was in your shoes (I was not too long ago) I would take sometime to read through everything listed in my original link or buy direct from e. Good luck!

1 Like

Thanks, I feel so close to getting there!

However I’m stuck on this step

Keep getting errors :pensive:

Does anyone have experience with this and know a solution? I feel like I’ve followed all the steps multiple times. Losing sleep over this every night I try to solve it.

HELP! :sweat_smile:

I’m this :pinching_hand: close to selling my soul to Google and just keeping my stock firmware.

Have you removed all accounts, passwords, fingerprints, etc. from the stock ROM before moving forward with the e flash? If not, this can cause issues. I am not 100% sure on this specific “Error: 1” but think it could stem from not removing the said protections.

Witch TWRP version have you installed ?

I have no accounts or passwords loaded. New phone.

1 Like

I tried the latest one


but read on another forum that trying an older version could work, so I tried a slightly older one (twrp-3.5.0_9-1-starlte.img) but had the same result.

Have you rebooted to recovery after format /data ?
What is package. zip ?

It seems I don’t have access to /data for some reason.
I’m not sure why it shows as

… and where did it come from?

I was attempting to patch the phone with

adb sideload

I just realised you meant the option on the first Wipe screen, I was trying under Advanced Wipe.

I managed to format Data. Only error was mounting ‘/preload’

after >wipe >Format /Data, tip yes,
go back to the main menu, choose reboot to recovery
you can try >wipe >advanced wipe >select /preload, swipe to confirm.
and retry to apply the patch,
in the offficial documentation it is not clear ( why this /boot patch ? only for the s9 ! when apply it ? )
it could be unusefull now, it could be for oreo-stock-firmware ? or for TWRP 3.3.x-x ? or for TWRP 3.4.x-x ?

Thank you!

I managed to do a successful back up on TWRP for the first time!

Ok let me try the patch and take it from there.