Samsung Tab s6 Lite (SM-P610) - "failed to verify whole-file signature" at 47%

The Samsung Tab s6 Lite is on Android 12.

I finally got Odin to install recovery-e-1.7-s-20230111250406-dev-gta4xlwifi.img by renaming it to recovery.img and tar’ing it. Then used Odin 3.12 to install it. (Because I couldn’t get zadig/heimdall to recognize the device properly.)

So I was able to adb reboot recovery into /e recovery.

However when trying to adb sideload e-1.7-s-20230111250406-dev-gta4xlwifi (sha256 matches), at 47% progress, the install stops with “failed to verify whole-file signature”.

Any ideas on how I can get past this verification error?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Happens even if I try with microglineage’s recovery and lineage-19.1-20221218-microG-gta4xlwifi. Same at 47% progress, it fails with the “failed to verify whole-file signature” error.

Siince both the Lineage and /e recoveries had the same error, I decided to follow someone who installed TWRP.

Installed this TWRP:

Reboot into TWRP (have to hold down POWER+VOL-UP+while_cable_is_connected_to_computer). Yay!

I copied e-1.7-s-20230111250406-dev-gta4xlwifi onto a SD card and used TWRP Install: reboot into recovery, format data. Install /e rom. Then reboot into TWRP recovery. Then wipe cache/dalvik.

Then reboot into system -->> bouncing e logo forever. :frowning:

Is there a way to tell if TWRP flashed the /e rom properly (which in this case I don’t think so), by looking at the TWRP Advanced File Manager?

That is, is /data supposed to have the normal Android directory that we can see when we plug an Android device into a computer (Alarms, Android, DCIM, Documents, etc)?

Is it the case that you never ran the First start wizard ?

If First start wizard never happened … ensure battery is >70%, go to TWRP and Factory reset. If /e/OS failed first boot, this will provide a second opportunity.

Correct - it never got past the bouncing e to the first start wizard.

Battery is > 70%. But I don’t see a Factory Reset option in TWRP.

It is under Wipe … Swipe to Factory reset.

Could it be du to installed Samsung firmware later than october 2022 ?

Are you saying that the is not new enough for whatever Samsung firmware was on the tablet before?

And that I would need to wait for the next /e rom to come out?

You can roll back if it is the case
(under some limitations : BIT/BINARY value of samsung firmware have to be the same)


In case of the (XEF) french firmware for the p610 it is currently "2"

Are you sure your device is still on stock Android 12 (S) firmware? not Android 13 (T) released in january

From the first attempt and not being able to get past the bouncing /e logo, I had to reflash a stock Android 12 Samsung ROM (since Android 12 was on the tablet when I got it).

Can I reflash a stock Android 11 Samsung ROM and then try again with gta4xlwifi/

I did so. Waited 20 minutes but still bouncing /e logo. Powered it off.

Looks like it’s back to a re-install of a stock Android 12 Samsung ROM.

When I got the tablet (used) recently, I believe that it was running Android 12.

Ok. I finally got zadig to work. I had to select the 2nd Gadget Serial device and flash to WinUSB.

choco install heimdall (to install heimdall 1.4.2.)

Then heimdall print-pit worked.

So I installed the /e recovery and it installed successfully!

Thank God! It was my first real use of zadig and Heimdall, as I had been using Odin.

1 Like

where did you get heimdall the one i got wont even open

  1. On Windows, I installed choco:

  1. Once choco was installed, then I installed the version of Heimdall in their repository:

choco install heimdall

. . .