SD Card "missing", Photo Gallery and App download not working :( FP3+

I tried to find a solution in the forum, but my problem seems to be slightly different and I’m at loss for a solution: I have a Fairphone 3+ and I formatted my sd (san disc) to be internal storage, not knowing, of course that this has proved to be a problem before.

Everytime my phone boots, I have a pop up saying “SD Card is missing”
I cannot take photos with the photo app - it crashes every time I try. And I cannot access the photos I have taken in the Gallery, because that crashes, as soon as I open it saying “No memory. No external memory available”. (Kein Speicher/Kein externer Speicher verfügbar)

After a while the screen goes dark and a pop up appears with “/e/ memory is terminated repeatedly” (/e/Speicher wird wiederholt beendet).

And I cannot download any apps from the /e/app store. This crashes ,too, saying “Apps is repeatedly terminated” (Apps wird wiederholt beendet)
Aurora App Store works fine, though.

I have already tried to connect the phone to my computer but no data is visible. There is just a blank space.

Also, I am unable to change the settings for the FP to store apps and photos on the phone again and ignore the sd card.

What can I do? Is there any chance of retrieving my data? And how do I tell my FP to ignore the SD card?

Thanks for any advice! :wink:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Can you “open” the card in Settings > Storage? On the next screen, you should find three dots in the top right, those should give you an option “Storage settings”. That should – normally – allow you to re-format the card (as portable storage, ideally).


When go to Settings/Storage and click on the three dots the only choice is “migrate Data” (Daten migrieren) - shall I click on that?

I would try that, yes (I never formatted a card as phone/internal storage, so I have no experience with the move myself).


I have clicked on “migrate data”
The next page says “move content to internal joined memory?” (Inhalte auf interner gemeinsamer Speicher verschieben?)
I have the option to move the content now or later, so I will click on now then…

There are no error pop ups on either the app store nor the photo gallery - and after a reboot it still says “sd card is missing” and I only see grey pictures, even though the number of the files is given correctly. Any idea what might help?

Oh, and thanks so much for answering me in the first place! :slight_smile: It helps not to be alone with such a matter.

I think I vaguely remember some people had the SD card showing twice after the re-formatting – both as part of the internal storage (what you are trying to leave behind) and as portable storage (“Mobiler Speicher”). If that’s the case with your phone right now, you might need to formally eject the “Internal storage” SD card in Settings > Storage.

Regarding retrieving the missing photos – I’m afraid I haven’t heard of anyone who has been able to rescue them from a card formatted as internal.


I would love to do that, but the sd card is not shown in my Settings/Storage. How can I eject it?

Did you re-format it as “portable storage” (“Mobiler Speicher”)?


Ahhh! just found it! I have the following options:
reformat as mobile storage
migrate data

Does it make any sense to try and reformat it as a mobile storage? Or shall I just eject it? :slight_smile:

I’d try “Reformat as mobile storage” first.


When I reboot the phone, the message is no longer there - thanks so much for helping!
I have lost all my pictures in the process, though. They are still grey :frowning: I guess there’s no way to regain them.

Thanks again anyways! :slight_smile:
Have a good night!


If you connect the sdcard to a computer and analyze it with testdisk or photorec, maybe you could rescue some of the files. But since it is 9 days ago, you probably have used the sdcard. So success rate will have been minimized.

Dear Bartmans,
thanks for this recommendation - I can still see the photofiles, but they are grey (no pictures, just grey quadradrangles) … I will try nevertheless. Thanks again!
Any help with this is very welcome :slight_smile: (Still have not lost hope completely…)

Can you open them on a computer or other device then?

No, I cannot upload them for example on my Dropbox…