Second DNS Server to set!

Hi everyone,

i have a NextCloudPi running with DNS Loopback in my homenet.

the iPhone Client can handle 2 manual DNS Servers in the Config, /e/ can handle only one!

So, if i went out of my homenet (Wifi) i have errors oft syncing my device and no Internet. I must turn DNS back to providers choice then it goes on.

Is there no Option to configure that?


Edit: i see it there was a github issue for this (i have a Gigaset GS 290 Machine)…

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Didn’t succeed, either :frowning:

Maybe using WiFi static IP (advanced AP settings) ?

Also, in NextCloudPi can you “spoof” your phone’s DNS server IP (let’s say using some kind of S-NAT ?
Something like (s) -> (d)
(may not work if using DNSSec).

No, that is not working for me…sry

So, there’s no way OOTB.

We may try to rely on an add-on app to automate switching settings.
Tasker can do the job, but it’s a paid application, only from Google PlayStore or Patreon subscription :frowning:

I found Easer could launch necessary commands, currently trying it …

i want a OotB Function of this Settings. Is this such an big programming problem?
On GitLab this “Issue” is more than 1 year old. (@Manoj)

My solution for this problem is to switch DNS manually on/off. If i in my Home WiFi i switch DNS to my Home DNS Server with intern IP. If i went out i switch on to the Providers DNS (Here i want to use automaticly an good privacy DNS Service i chosse by myself).

best regards


I am assuming you are referring to this issue. Checking with the dev team if we are planning a fix for it.

Many thx for your work and try for a fix for this problem!
Stay healthy!
Best regards

Is there an answer from dev Team between this issue?

Hi @anon48570964 i have asked Romain to set a milestone or share a reeponse. He is on leave this week. Should have an update by Monday.

Big THX @Manoj

Best regards