Selecting the spelling checker language (in Message)?

Using /e/OS 0.11:
I have two languages defined in System Settings, French and US English.
As for the keyboard, /e/OS offers the two languages and switching from one to the other, but this also changes the keyboard layout: I’m used to the French layout and thus only use the French one.

Now it looks like the spelling checker is somehow tied to the keyboard:
When typing an SMS in English (using the French keyboard layout), the French spelling checker kicks in all the time and wrongly fixes what it considers as spelling errors. Like changing “the” to “thé”, for instance. Aaaargh!
I suppose a similar problem exists using other apps such as Mail or anything when text can be entered and spell checked.

Is there a way to change that behavior without switching to the QWERTY keyboard (or going back all the way to overall settings and changing the global keyboard setting just for that SMS?)
I looked for a way to create a new virtual keyboard using a French layout with an English spelling checker and select either one from the keyboard app (it looks like the Google keyboard allows this). But I haven’t found how to do this.
Am I missing something?


take a look in Settings > System > Language & input > Virtual keyboard > Android Keyboard (AOSP) > Languages.

Disable Use system languages and enable French and English instead.

Thanks for your answer!
I just did and tried, but I didn’t notice any difference:
The spell checker still follows the selected keyboard, so I have to select the US QWERTY keyboard to get access to the English spell checker.
That’s also the behavior I had with “Use system languages”?

Maybe you won’t be able to have one keyboard for two languages with the AOSP keyboard, but you can set the english keyboard to be AZERTY :

Settings > System > Language & input > Virtual keyboard > Android Keyboard (AOSP) > Appearance & Layouts > Custom input styles. Select the keyboard you want (or create a new one) and set settings to “English” and “AZERTY”.

When I select “Appearance & Layouts” then “Custom input styles”, I get a fully blank page with nothing but the title:

<- Android Keyboard Settin…

Looks like I’m getting close, but not there yet! :frowning:

There is a “+” button on the top right.

Thanks ALOT. I finally figured it out!
I was able to create an AZERTY English (US) (AZERTY) keyboard, but it took me yet another little while to realize it was then created and listed in the “Active Input Methods” list.
After that, switching the English (US) off and English (US) (AZERTY) on wasn’t too hard to figure out. :smiley:

I wonder why the little “+” sign that you mentioned is actually grayed out to the point of being nearly invisible, though. I never tried it before because I thought it was de-activated.

Thanks again, it is soooo convenient to be able to switch the spell checker now!

1 Like