Setting the Default Keyboard

Hi - First time /e/ flasher :slight_smile:

I’m running /e/ on a Moto G4 with an /e/ ROM based on “Nougat”. Normally, there is a setting in Settings/Languages & input that allows you to set your default keyboard. This functionality is missing in /e/. I have root access - anybody know how to do that? Maybe a file deep in the underbelly of the Omega13 that says what the default keyboard is?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Do you mean something lime this?
Screenshot_20201116-204604

Than search in Settings for on screen keyboard

Well, there’s nothing that comes up for “On Screen Keyboard” but this is what comes back when I search for “Keyboard”

Screenshot_20201116-152259

Normally, you should see something like this:
image

It makes me dizzy when I see these keyboards. You know they spy?

Have you had a look in Apps/your keyboard?

Is there something to set it as default?

Oh, I’m not using any of the keyboards in the second screenshot - that was a picture taken off the internet. I had to find it there to show you where the “Default keyboard” selection was because it isn’t on my phone.

I don’t have an app called “Your Keyboard”. I don’t see anything called “Your Keyboard” in “Settings/Apps/Configure apps”. Am I looking in the right place?

‘Your keyboard’ was the synonym for the name of the keyboard you are using. AOSP keyboard or AnySoftKeyboard :wink:

1 Like

Default keyboard is AOSP. I’m not using the AnySoft keyboard - I prefer “Hacker’s Keyboard” when look-ahead correction is unavailable, which it is when you’re not uploading stuff to Google servers.

I looked through all the settings in the AOSP keyboard - I don’t see anything in the settings that addresses the default keyboard.

Not sure why the decision was made to make the choice of the default keyboard unavailable. However, as you know, my phone is rooted so if you know what file the default keyboard is set, I can go and fix it.

I don’t understand what issue you have. Are the keyboards swapping all the time?
In AOSP keyboard have you pushed longer on the ‘Eart’ left of ‘Blank’ key? There you can decide which keyboard should be used,

1 Like

Well, basically, it’s this:

  1. I enter an app that I have to type something in.
  2. I select my preferred keyboard.
  3. I close that app and go to a different app where I need to type something in.
  4. I select my preferred keyboard.
  5. I go back to the first app.
  6. I select my preferred keyboard.

I would like to go into an app and not have to select my preferred keyboard.

By the way, I’m sorry - I was incorrect. Apparently, only some ROMS allow the user to change the default keyboard. Still, it would be nice if I could change the default keyboard in this ROM.

And now, it’s working. Hacker’s Keyboard is coming up in all my apps. It’s even coming up after I rebooted. Don’t know what happened. Why do I even come here? If I wait a while, the problem goes away … :slight_smile: