Setting up a printer in /e/


trying to setup a printer on Samsung S7 Edge. Installed the CUPS app on F-droid which provides a service under Settings->Printing. The phone is not finding the printer so I set it manually with lpd:// This is the link that is discovered on the same network by my Debian Linux machine so I would expect it to work on the phone too. I’ve also tried which also works on the Linux but that too fails.

This is not a network problem or it would be a problem for the Linux desktop too. I’m wondering whether its the app. Anyone managed to set up a printer in /e/? Using the CUPs app (v1.5.0) or some other service? I’d like to avoid using the Epson app which probably has loads of trackers and I would have to get it off Play Store anyway.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

For my Brother laser printer to work (WiFi), I had to install something called “Brother Print Service Plugin”.
It isn’t a full app with tons of trackers, just a print service driver (displayed aside of “Default Print Service”).

For Epson you may try
(NB : I didn’t checked if it has trackers …)

Cheers. Downloaded it from an old phone that still has a Google account (use it when desperate …). Difficult to say whether it has trackers as ClassyShart3xodus can’t see it. Looks like its just a bunch of drivers. In fact, my printer is now visible on the phone.

Historically, I was using Epson iPrint. ClassyShark2xous reports 2 trackers.

You can also get it delivered directly to your phone using Aurora Store :

Hi everyone,
my current problem is that after entering the IP of the HP printer connected to my router, my samsung S8 (/e/OS 0.9-2020062560240) do not recognize it.
I’m on Linux Mint and from there the printer is working. Its IP number is not under DHCP so it’s always the same.
I also tried the CUPS lpd://192… but in that case /e/OS do not even allow to add the printer.
Any hint on how to connect the printer ?

Search for “HP Print Service Plugin” in Apps.
Unfortunately it has 3 trackers, you can block them with TrackerControl :wink:

If your printer is on a CUPS server, you have to install the CUPS printer app (available in the /e/ Apps installer).

1 Like

Interesting, thanks !
My printer has an integrated CUPS server, I’ll give it a try :slight_smile:

Not sure if my printer is on a CUPS server or has one built in. Surely enough the CUPS printer app has accepted the IP number.

Now: how can I check that my phone can print some text from, say, an emai?l

Once the CUPS printer app is installed, you don’t even have to open it. Just go in Settings > ??? > Printers and now the printer will be detected (if it’s CUPS compatible) and you know you can print with it if there is a print button next to the thing you want to print (a PDF for instance).

Hi I tried to setup CUPS printing and failed, I’m now using this App Mopria Print Service its available on the /e/ App store it has a few trackers but it works well, my printer is an Epson.

For your infirmation, an EPSON Print app exists.

Success !! But through a winding way.
My vodafone station has definitely a bug, since is not possible to operate it as a CUPS server.
In fact it connects the printer through the USB port, my linux computer sees it but it is always not enabled.
The printer is operating properly only through an Ethernet connection to the router and a "socket://192.168… CUPS connection on the linux box.

So the workaround I used was to keep the computer on and share the printer.
Not so handy, but it works.
Thanks to Anonyme for showing me the way

Edit: the extra Android CUPS app is no longer necessary: it works the default one

This tracker control app is really cool. Thanks for pointing out.