Sideload error Installing /e/ on LG V20 918 (Tmobile)

I am in the /e/ TWRP and am to the point where I run the adb sideload command to flash /e/ to the phone. It took a LOT of shenanigans to get to this point, but as far as I know, they don’t have any effect on the current issue.

When I execute “adb sideload [FILENAME].zip” it gets to 47% then stops with the line
“Total xfer: 1.00x”

The phone displays the following lines regarding the error:

Comparing TZ versions:
Min TZ version: TZ.BF.4.0.1-102060
Current TZ version: TZ.BF.4.0.1-71441
assert failed:msm8996.verify_min_trustzone(“TZ.BF.4.0.1-102060”) == “1”
E:Error in /sideload/ (status 1)

I’m not an expert with any of this stuff, but what I’ve gathered from fumbling around forums is that trustzone is some firmware thing, and the one on my phone is outdated compared to what /e/ is expecting. Therefore I tried using the oldest available version of /e/, as well as installing any updates the stock OS offered me. No change.

There were a few forum posts about similar issues, but I wasn’t able to figure out the solution from them, so any help is very much appreciated.

Maybe some interesting readings @ XDA ?

How can you view beforehand 1. the TZ firmware version /e/ is basing the build from and 2. how can i confirm the source the /e/ is referecing firmwares

This will be the device tree for the /e/ system GitHub - LineageOS/android_device_lge_v20-common.

The underlying firmware /e/ has to work with will meet this guidance:

If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I guess your problem is identifying the very last firmware released. That is what will have been used when extracting the blobs for the device tree.

Then you must make sure to flash it nicely on the device.

Some TZ-related links (for Xiaomi, but may be of interest anyway) : Cannot install /e/ 2019080719469 on Xiaomi Mi Mix 2 (Chiron): assert failed: xiaomi.verify_trustzone("TZ.BF.4.0.6-00124","TZ.BF.4.0.6-00130") == "1"error: 25 (#476) · Issues · e / Backlog · GitLab

1 Like