Signal and Telegram: background running notifications pinned in dropdown menu

Hi, I got a /e/ preinstalled Fairphone 3 and use Telegram and Signal. Both have permission to run in the background (in Telegram, this permission is ticked in the app settings, and in Signal I think it’s like that by default, because I couldn’t find this option anywhere). The problem is that I have pinned notifications in the dropdown menu telling me that they are runing in the background (as seen in the picture). Of course, this information I don’t need to see it everytime a new message arrives and use this dropdown menu. It’s not a big deal, but it quite interferes when looking at legit notifications in this dropdown menu. Anyone experiencing this problem?

Long push on notification and select ‘minimize’ and viola … it’s gone :slight_smile:

1 Like

Thanks @harvey186 ! But if I minimize this notifications from Signal and Telegram, I will still receive notifications of incoming messages in this apps?

Yes, it’s only for the status notification

Great. Thank you very much! :grinning:

it was me a pleasure :slight_smile:

Ups, looks like they’re back again… I followed your instructions and minimized the notifications, and the message thrown was (this apps will minimize). But they’re still there. If I long press them again, the same message appears, but they continue there, and the only other option is to revert the action, which I dont want to do because I do want to minimize.

Edit: I pushed “manage notifications” button under this notifications, and that took me to the Settings,>Notifications menu. Then when tapping the apps, in Telegram I managed to untick the “background running” notifications, and in Signal I untick the “others” notification, and that did the trick.



Thx @graz, i used your last message and it’s OK :slight_smile:


Hello ! Under nougat it seems, “others” notifications doesn’t exist for signal.
Can you take a screenshot ?

Sure @TheMajorTom. Here you are

Thanks @graz ! This option is not available under nougat…or i can’t find it…

Yeah, not available. It’s the same with the Delta.Chat notification.

Thx @graz… works well.

Very helpful, thank you :slight_smile:

For /e/-Android 7 / Nougat, this worked for me:
i.e.: "Seems like you can get rid of the notification (at least for a while) with the following trick:

  • Slide the notification to the right and open “more settings” (or long press it)
  • Click on the “A”
  • Put the slider to the top left (all Signal notifications are gone)
  • Press on A again (now again other Signal notifications will come in as usual)
  • Other notifications or even opening the app does not bring the persistant notification back.
  • This will last until Signal app (for whatever reason) restarts."

Edit 2020-10-27 : Hmm, sorry, this is only a very temporary solution. After a few hours the notification is back.