SIGNAL background connection enabled


for a short time now I use a Samsung S7 Edge:
Android 7.1.2
System version 0.11-20200831170819
Device model SM-G935F

The status bar permanently shows ‘SIGNAL background connection enabled’. I would like to get rid off. Pressing the message a little bit longer displays just 3 options:

  • show notifications silently
  • block all notifications
  • don’t silence or block
  • more settings

But none of these prevents ‘SIGNAL background connection enabled’

Thank you

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Yes, Signal has a lot of notifications you will normally not need.

You can go into the Settings -> Apps and Notifications -> Signal -> Notifications. There you find a long list of check boxes you can switch off or on. In my case there are only Standard and Errors checked.


to hide this notification, go into:

Settings > Notifications > Signal > in the “Importance” section, click on the blue “A” to be able to manually set the importance level of the notifications, then move the blue dot to the left as far as you can.

1 Like

Those options are not present in Android 7.

You have to keep it

But in this way, you loose also the other notifications like messages

Dear all,

the disturbing message vanished with notification importance level 1. But 1 is too low for my kind of usage, so it must be any other setting. I have had the same phone/model before and was able to prevent this message from popping up…but I can not remember which setting it was. I assume it was in the area of ‘battery optimisation’. There Signal is one of the ‘not optimised’ apps. I am pretty sure I solved this in the past somewhere else but not in the ‘importance’ setting.

Oh yes indeed I didn’t think about that.

So the only solution on Android 7 (Nougat) to have notifications for calls and messages but not this persistent notification is to use Google Cloud Messaging in order to receive notifications instead of the built-in notification system in Signal requiring the persistent notification.

So go into Settings > MicroG > Google Cloud Messaging. If you see “Current State : Disconnected” and no app listed, open the “Phone” app and dial this code : *#*#2432546#*#*

Now you should see “Current state : Connected since xx seconds”. Re-install Signal (you can backup your messages if you want) it it will use Google Cloud Messaging.

My MicroG / Google Cloud Messaging is ‘connected’. But re-installing Signal does not result to show it as registred app using Google Cloud Messaging. How could I force an app to use ‘Google Cloud Messaging.’ ?

If you want, there’s a fork made by a developer that does exactly what you asked, and also reinserted the option to export messages in plain text.

“- Choose between FCM or websocket notification delivery.”