Signal not working properly on /e/

You mean this one, right? Signal-FOSS - TwinHelix

Like I mentioned, I already tried it to no avail

When I try to add Signal to the accounts in settings, it doesn’t work nothing happened. Maybe this has something to do with it?

Install the Signal Fork (Foss).
Complete the setup of the app by launching it and following the instructions.
When you are done, you will find the signal entry under accounts, but it was added by the app, not manually.

according to my experience, the account transfer does not work - or at least not with any of my devices that I had here for testing.
There is also the “manual” method, by setting up a backup, which is then transferred to the other phone and then restored using the previously specified passphrase.

Do you mean the one I linked above?

Yes, that one.

or Langis (Signal name inverted) for android without Gapps or microG installed

or the offical one from the website (if you don’t mind proprietary blobs) / play store (aurora store)

I had all versions running on my S10+ as I was testing which worked best for me. I sticked with the TwinHelix, FOSS one.

/e/ is using mircog which makes it able to use GCM (Google Cloud Messaging) it’s possible that the non-foss versions are actually registering to that service and that’s why it’s not working. Check your settings under microg and make sure that it’s disabled if you’re using a “unoffical” version of signal. (in the FOSS one (twinhelix) GCM has been disabled via a patch, that’s why you get that notification that google services are disabled on the device) You can change it in the microg settings per app or for all

If telegram works fine, are you using the offical client or Telegram-Foss?
Again the difference is the use of GCM or not. (by default)

I am using the official one from Aurora, at least I think that’s the official one.

And I already tried every Signal fork you mentioned, none are working.

Like I mentioned on my other phone (Z5 Premium) the official one from Aurora works fine and gives me the google services followed by “are you a human captcha” treatment. Which I wouldn’t mind not getting, but after that contacts show up.

Also, this is off topic: But I am testing the navigation and both Magic Earth and Osmand show my current location way off, which is kind of important for me, since I have a meeting coming up in a few days.

It’s really silly that you cannot connect to the service at all. That’s not normal…

Signal needs access permissions to your contacts, which is something it usually asks you about once you completed the initial setup.

It asks me about permissions about contacts and after I go through the initial steps it even shows up in signals’ settings. Pretty much everything besides location and something else was set. But it doesn’t show up under settings > accounts, and I cannot add it either, I can try, but nothing changes

Aurora is a front end for the google play store, so yes, if you downloaded it from there it’s the official client which uses GCM by default. (obviously)
So, if you’re using that and have no issues, then we can at least rule out that microg and the GCM implementation isn’t working correctly.

Just to rule this out, did you update to the latest offical firmware from Samsung (System Update) before installing /e/?

None work on my S10

On my Z5 Premium running LOS the Aurora works fine, and haven’t tested other ones because of that. I just mentioned it as a comparison.

The one that comes “close” with the whole google captcha thing is the FOSS one, when I compare it to what happens on my Z5 signing up

Does the navigation app have access to location service?

At first I did (Android 11), then I soft bricked (download mode loop) thenI installed the most recent stock I could find for my country. I then checked for updates and it wanted to update to Android 12, which I didn’t do, since, as far as I can remember documentations only mentioned 10 and 11

Yes, they all do. I tried Waze right now: same issue.

That’s because you’re using Lineage without microg on your Z5.

I’m not sure where this error comes from tbh. The build for the S10 is still beta, and from august last year, so it’s possible that there are some bugs which are now causing these issues on your end.

As a workaround you might try the microg fork of lineage for your device which should have a more up to date build. and try /e/ again when they release version 0.20 also for the R versions, S10 included.

I did install microG as an App aftewards.

But is there any advantage to using the microG fork over regular LOS and installing MicroG after?

Unfortunately, that is probably the route I have to go for now, and hope my issues disappear. I really wanted to try /e/ though. And I have to set up the whole phone with its apps again :/.

Also is there anything I have to be careful about when I install LOS again or simply follow the regular steps?

The main difference from the FAQ:
Why do we need a custom build of LineageOS to have microG? Can’t I install microG on the official LineageOS?
MicroG requires a patch called “signature spoofing”, which allows the microG’s apps to spoof themselves as Google Apps. (…)

It seems like some apps work without that spoofing enabled. (?)

You can follow the official lineage instructions, even when installing the microg fork

obviously because you have already unlocked the bootloader you can skip that part.
Boot into download mode → install the new lineage recovery → boot into recovery → format data & sideload → reboot. (in short)

1 Like