Silver Linings and assorted WTF-type questions

I was among the first people to get a refurbished S7 Edge with /e/OS preinstalled. Tentatively, I think there was something wrong, either with the ROM that was flashed, or in the manner it was flashed onto the phone … although it’s also quite possible that I inadvertently did something to it, to introduce the bug(s). This thread is to document the history and (apparent) resolution of the issue.

The discovery of this issue comes up in the course of this thread (warning: I lost my mind a bit, near the end, after my phone got wiped): Is the bootloader locked? How to unlock/access on pre-installed phones?

The basic issue was that TWRP could not mount or read my internal storage … this seems to not be unique, as I’ve found several forums/blogs documenting ways to fix it. But why it was an issue on my phone in the first place, is the point of this thread.

Ultimately, I ended up following the recommendations in this site:

After following steps 8 and 9 (change filesystem to ext2, then “back” to ext4), that is when my phone lost all of my personal data, apps, settings, etc, and reverted to, roughly, the original /e/OS condition it was in when I first received the phone.

After that, while trying to restore from a previous TWRP full backup, TWRP warned me that the backup had actually been made on an ext3 filesystem … so, the only hypothesis I have is that the phone’s main partition was originally ext3, I changed it to ext2, then to ext4, then tried to reboot it, and that scrambled the OS.

Restoring the TWRP backup did not restore any of my internal data (except photos?!?) … and that’s a known thing – TWRP does not actually back up your personal data with its “full” backup (and so why the hell do they call it a full backup?!? That is the exact opposite of a full backup … but I digress). I tried switching back to ext3 filesystem and re-restoring the backup, but no joy.

On the other hand, the original “TWRP can’t see my internal storage” problem was in fact resolved. So … yeay, I guess.

Whatever … in the end, I was stuck with, basically, a factory-reset version of my phone. Except …

It works better now.

The most obvious example is the camera. My Open Camera app has been absolutely horrible since the day I got the phone, barely usable. I have never–not once in 8 months–successfully taken a picture with flash … the app always errors out. And non-flash photos periodically errored out, as well, about 1 in 5. Even when non-flash photos worked, it took–I’m not exaggerating–anywhere from 1.5 to 5 seconds after I pressed the button, for the camera to actually capture an image. Focus and resolution were variable, but generally very bad.

… until this OS reset occurred. Now the camera works pretty well. Photo quality is not stellar, but it is much, much better than before. Time from ‘click’ to image capture is uniformly less than 0.5 seconds, sometimes much less. Flash photos work. I could go on.

There are many other things about the phone that are now better, as well … although they are relatively minor and subtle, and I can’t be 100% sure I’m not just imagining it. I think my Pedometer app is more accurate. It used to take 10-20 steps before it would start counting. It’s much faster to recognize my movement now. And again, I may be imagining this, but I swear the actual screen display is better – crisper, sharper, as though the resolution improved.

So, you know … silver linings.

Why is the phone working better now?

Seriously … what could have possibly happened that caused the OS to improve?

My only hypothesis is this … I have installed at least 4 OTA system patches over the past 8 months. Is it possible that those patches have not actually been getting successfully applied, despite my phone OS telling me they were?

That’s my only guess, that all this time, I’ve been running on the original version of the OS, not actually getting the patches I thought I was getting … and that this reset actually did successfully update itself to the latest version (or at least, a more recent version) … phone today tells me I am running System version 0.7-2019110830013, from last November, and that there is a Jan 6th update available to install.

So, there you go … documented. I always try to keep in mind that this Whole Project is still one big Beta test. 80% or more of my personal data (the critical stuff) was all backed up elsewhere, so this has mostly been just a gross inconvenience for me.

However, if anyone at “/e/ Central” would like to weigh in, I’d love to hear theories on what was wrong with my phone originally (such that TWRP couldn’t read it), and how/why the OS just magically started working better.

1 Like