SIM-card not detected

i bought a Gigaset GS290 and installed e-0.18 by easy installer. Sadly my SIM-card (german) will not be detected in both slots. Then i reinstalled Android stockrom with the same result. Does somebody knows what to do?

few hours later:
fixed with: Erase all data (factory reset)… sometimes it’s to easy, isn’t it?

Manoj, My Teracube Emerald – which is a T-Mobile certified device – came with this text as soon as I turned it on. ""We see your phone does not have correct settings to access the internet or send MMS. Settings will be sent to your handset” The text was from “2903.”
The phone worked for month, connected automatically and all the APN settings are correct for T-Mobile. But then it stopped.
I returned it to Florida (I live in New York City) and recently received a replacement which works one or two hour a day and then “emergency calls only – no sim detected.”
T-Mobile says my sim is correct and Factory Reset with it in either of the two slots still produces “no sim detected.”
Could Easy Loader to re-load the OS save me ?

Looks like a hardware issue. Since it is purchase from our store, Pl send a mail to <> and share the issue details if not already done. That would be a better option than attempting to service it yourself.

But my original phone and the replacement Both might have this “hardware issue?”
But thank you, I’ll go to has repeatedly not been able to help – except, of course, send me a replacement at no cost. That took 3 weeks, but at least they did it.

I’m not sure I have the right place, but I emailed the description of my problem to:

I’m not sure I’ve sent it to the right place, but I’ve described my problem to:

The email ID you have to send details to is
Also, where did you purchase the phone from? Was it from as we have stopped the sales of GS290.
Could you let me know where you got the address from?

Manoj, Just to say that I sent the description of my possible “hardware Issue” on my two different Teracube Emeralds to on Sunday night so they would have it Monday morning – even mentioning your name. But now at the end of Tuesday, I haven’t heard anything yet.

This might be normal? I hope everyone’s not on summer holiday.

Thank you.


I saw that mail in the helpdesk queue. Will ask them to respond ASAP

i can manage to wait – as long as it’s in the queue. Thank you.


Actually, maybe I wouldn’t mind the bump up in the queue that you suggested.

I’ve been w/o a phone at all for almost a month now and it’s been a learning experience. I know; I know; I should have followed /e/'s advice and not tried to use my Teracube my daily driver, but my old Samsung s7 with /e/ was no longer being supported by T-Mobile but Teracube is so . . . .

And if it really is a hardware problem, there’ll have to be another exchange/

Ok, ok – I’ll just listen for what they say.


I am assuming you purchased the device from the Murena store

Yes, I think so. Is that the same as Murena has two phones – one w/ /e/ and one w/o. I bought the one with /e/.

It was shipped to from

ESolutions SAS

Alexis Noetinger in Lakewood, New Jersey.

And for my first replacement, I dealt with Michel at

Both came with that odd message from “2903:”

"We see your phone does not have correct settings to access the

internet or send MMS. Settings will be sent to your handset. “

I hope I’m answering your question?

I’m going to be out of email touch for about 3 hours now.


Thanks for the details. This phone was purchased from us. The team members are aware of your issue and I saw a response on the thread in the helpdesk. Pl share the details they have asked for, and we will work on a resolution to your issue ASAP.


Below is a slightly shorter version of what I sent to Shenol three days ago but I wanted to make sure you saw it also.

Shenol, I think I have to start being deeply apologetic. The best-of-all T-Mobile sales person discovered a scratch on my sim. He tried a new one and for the last 12 hours [4 days now] my Emerald has been perfect.

I realize that the earlier technician after telling that my sim was the newest T-mobile type because it shows R-15 in red letters, put it in the Emerald and the Emerald worked when I left the store – but for only one day. What he did not do was look at its other side which the man yesterday did. After saying that he didn’t like the look of mine, he put mine and a new one side by side on the table and we saw that there was a scratch on mine.

What now? First, I should offer to pay any kind of service charge you might have for “badly-informed customers who ask you to solve a problem that doesn’t exit.” Secondly, if there’s no service charge, maybe I should humbly contribute to Teracube? Not only have you spent your thought power, but /e/ replaced my first Emerald for free, and now I think it wasn’t even defective.

I will send this same message to Michel at . Is he a different part of your service team?

apologetically, stanley

1 Like

Hi Stanley,
Thanks for sharing the updates on what happened. The best part is that your problem was resolved. Let’s move on from there. We all learn from our experiences. The next time, we will add this as one of the checks in the process of troubleshooting (if it was not already there).


1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.