SIM not detected SM-G960F after OTA Upgrade

I am afraid this is reported by many! Please can you send an email to, asking to them to enable login for you

Issue created: SIM not detected SM-G960F after OTA Upgrade (#4855) · Issues · e / Backlog · GitLab

1 Like


I have a Samsung SM-G960F,

I have E fondation OS install with exe program.
I have do the last update : actually on my phone : e-sarlte-userdebug 10 QQ3A.200805.001 eng.root.20220201.120616 dev-keys,stable-release
And i cant note use DATA on my sim card. The option is actived on the panel, but i can not use internet.

It seems that I am not the only one with this problem related to the sim card, but I take the liberty of pointing it out to you because it is an important problem. I sent a ticket to,

Thanks for your feedback.

1 Like

Hi @Stilgar, welcome to the /e/ forum. Sorry to hear this and thanks for your report. However if you want to make the developers aware please review @liotier’s Gitlab issue linked above and add full details of your experience.

Please @aibd, should I wait for a solution or should I accept that I need to reinstall a lesser version that does not suffer from this problem ? In the second, painful, case, what version should I chose ?

lesser version

One might take the view that the Samsung 9’s got stuck at Oreo because of this very difficulty of the Upgrade to Android 10, Q.

As “stable” appears right now to have gone unstable, I am guessing that only a robust fix could restore stable … so perhaps this explains the delay. I am in no way qualified to speak for the /e/ team.

if you decided to go for a reinstall without /e/ team support, I guess you would need to convince yourself that you felt dev is not the lesser choice today !

Please check out the following
Know your hardware - Samsung

Put another way, do you think it is useful to the development and quality assurance process that I keep my S9 in its current state for the purpose of being a guinea pig for testing a fix, or would that not be useful - in which case I might as well schedule the installation of 0.16, 0.17 or 0.18 ?

Generally in the upgrade from Oreo to Q, you would have to make a full backup or have to start again with all your apps. Did you stuff (your data) survive this incident? Did the majority of the system appear to survive the upgrade?

SIM not detected and unstable Bluetooth are the only faults. Everything else is nominal and I’m still using this S9 daily, reaching the Internet through a spare device set up as a Wi-Fi access point routing to LTE.

What local data exists is mostly cache for IMAP, *DAV and Matrix - everything else is synchronized through Syncthing.

Thanks for confirming, one other thing, how practical would it be to undo Rooting? This is only a guess, but I it might have been possible that rooting got in the way of the automatic upgrade.

I am not recommending this yet but it might be worth a very simple reflash of system.

However as you have SIM problem I was first drawn to fully reflash with a stock ROM.

@Manoj, can you hazard a guess whether @liotier might see any sort of response to his gitlab issue before the weekend, thank you. I wish I had a clue of how the automatic upgrade works, if I looked harder would I find it?

The team is aware of this issue, besides others raised on this forum around s9 upgrades. I do not think we tested on rooted devices. Maybe we should add a warning regarding this.


You are thinking in a most altruistic way !

In my view the ota-upgrade itself was the problem (not the /e/ version or Android version), so I feel there is no need to downgrade /e/ version or Android version. The only (in my view marginal) downgrade is stable → dev.

Some might say that there is another unknown; if you change channels (that is stable/dev) but in my view a bigger risk element if you do an unsuccessful downgrade from Android 10 to 8,

The big unknown is we are not told the “magic” of this upgrade method.

These links cover the choice of published ROMs available to you:

Downloads for the starlte

To understand the difference between /e/OS builds check

Thanks, I’m used to supporting Free software… I sit at the Board of the Openstreetmap Foundation, I’ve had 25 years of Debian administration and I am currently nursing my OPNSense router whose “OTA” upgrade also broke (the same spare devices used as Wi-Fi router for the S9 is currently the backup for my home’s 1Gb/s FTTH)… I suppose I’m more patient than the average user - I know what it is like !

I have never done it, but for the purpose of testing I can do that, if you find it useful.

Meanwhile I have attached some requested adb logs to the ticket.

I suppose that the likes of Could not find '' could also mean that my hardware is fried, though Wi-Fi works fine and the problem occurring right as the upgrade finishes makes the hardware failure hypothesis extremely unlikely.

1 Like

Hi Jean-Marc,

I so glad to see that your Gitlab issue is now in hands of an expert assignee ! I feel you do not need to be doing any guess at my impulse. I am confident you will get the support you need. Good luck.

1 Like

Sorry for the delay, I’m struggling a bit.

adb sideload failed:

% adb sideload
serving: ''  (~2%)    adb: failed to read command: Success

So I’ve tried copying through ‘adb push’ :

% adb push  /storage/emulated/0/ 1 file pushed. 28.4 MB/s (339804044 bytes in 11.405s)
% adb shell ls -alh /storage/emulated/0/
total 162M
drwxrwx--x  2 root sdcard_rw 4.0K 2022-02-23 23:49 .
drwxrwx--x 27 root sdcard_rw 4.0K 2022-02-23 22:58 ..
-rw-rw----  1 root sdcard_rw 324M 2022-02-21 10:49

But the file doesn’t appear in any file browser on the S9, particularly not in TWRP… I’m puzzled.

So I just mounted the SDcard on my workstation and copied it to the root of its filesystem - now TWRP sees it.

On booting TWRP:

  • I cancel password entry, because I have no idea what password TWRP asks for, and I dont remember encrypting a partition (that install was long ago)
  • I “Swipe to Allow Modifications” (no idea if that’s the right way but modifications sounds like what I’m attempting)
  • I choose “Install” and navigate the file browser to
  • With default options (only one checked is “Skip Digest…”) I “Swipe to confirm Flash”
  • Less than half a screen of output prints, ending with “Upgrading software” and the device instantly reboots into an unmodified system. That last incident reminds of adb sideload failing after 2%

So, no luck with the image supplied by @Stricted. Am I doing it wrong ?

Sounds like you got it right in your final run. Just to run through your post,

In order for sideload to work in TWRP you would need to do Advanced > ADB Sideload.

Your instructions were “Please flash it through the recovery”

The 2 options I would consider are copy with a PC to SD card or adb push to /sdcard or /external_sd.

In TWRP at “Password” when you know no password exists, Cancel :white_check_mark:

“Swipe to Allow Modifications” :white_check_mark:

I choose “Install” and navigate the file browser to :white_check_mark:

I think you covered:

“Swipe to confirm Flash”, you do not want signature verification.

In this case “Automatic reboot” is ok.

There is a set of images in this thread - does your phone deviate from those images / method? B) Transfer the /e/ ROM to the internal storage of the smartphone. (At this point in the tutorial, we are loading a ROM, but same sequences would apply)

Looks like I followed a correct method.

The image is only available from the sdcard though: in TWRP, the image I copied to the root of the main storage (using some file manager on the booted /e/) is invisible.

Also, in the “Select Storage” dialog, the “Micro SD card” appears as with its correct size but it also shows “Internal Storage (0MB)” … Symptom of an anomaly ?

It seems that your SD card was originally installed as “Internal storage”. This was thought “useful” but actually caused problems to many (me included!). It is now no longer recommended. Whether this affects your main issue I cannot say.

In a regularly installed Android system we see the “internal storage” of the device mounted at


while the SD card is mounted at


If, say, you do not see /external_sd at all on TWRP this would point to “SD installed as internal storage”.

1 Like

After installing the “vendors” file, I succeeded in installing e-0.20-o-20220118158074. Before rebooting, I attempted installing the image supplied by @Stricted but the device instantly reboots before completing installation.

Back to vendors and then system image - and I reboot the device with a fresh /e/ but alas, with e-0.20-o-20220118158074 too, no SIM detected (I checked the SIM again, working on another device).

hmmm … the second part of the reply to your Gitlab issue was

let me know if it solved the problem

My reading of the situation is that you were given a “safe fix” to see if a damage to the vendor partition had occurred. From a troubleshooting point of view, they really need to know the answer is no !

However you may have provided other/new clues, worth reporting.

(I will just mention that I think you and @quadcopterman might be in the same position of having “gone back to Oreo”.)