Slack push notification doesn't work

Hi,

I recently downloaded Slack for my work and I do need the push notification system (which isn’t working).
I’m wondering if there is a solution to activate notification. I have read some threads about FCM, GCM but I’m still lost (and I don’t understand the difference between these two).

In microG preferences / Google Cloud Messaging I see that Firefox and Push Notification Tester are registered but no other app. Is this normal ?
I’m using a Samsung s5 mini ( SM-G800F), with the 0.9-p-20200606-UNOFFICIAL-kminilte build.

Thanks in advance for your help,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Some apps re not working without original play services. For example, Protonmail is not sending push messages without original play service. So I fear, on Sack it will be the same. Best, you will ask the Slack support, how getting push messages without original play service.

Ok, so I can’t expect push notification.

Thanks !

Hello,

I have working notifications works on Slack and Proton Mail (tested on S7 and Fairphone 3).

In Slack, to test notifications, go to You > Notifications > Troubleshoot notifications and you will see something like that :

It will tell you if something is wrong.

On my S7, I had to register the device to Firebase Cloud Messaging to have notifications on Slack (microG required). This page will explain how to do it : https://github.com/microg/android_packages_apps_GmsCore/wiki/Helpful-Information

Hi, welcome in the forum :slight_smile:

Is your issue solved ?

If not, could you provide a screenshot of what you see in Settings > MicroG > Google Cloud Messaging please ?

Hi @Ceddev,

I’m having trouble setting up Push Notifications for Slack on my S7. When I go to Troubleshoot Notifications, I get an error starting with Token Registration. Could you explain what you did to register your device with FCM? It wasn’t clear to me from the microg link.

I’m not sure if it’s relevant, but I’m running Slack in a work profile with Shelter.

Thanks,
Deepee

Since your app is in a work profile, you have to open the MicroG that is in the work profile.

To do so, open Shelter, go into the work profile tab, click on microG Gms Core and open it. Then take a screenshot of the Google Cloud Messaging section please.

Thanks @Anonyme. Here you are:

Open the Phone app (of the work profile) and dial this code: *#*#2432546#*#*

You should now see Connected instead of Disconnected. Re-open Slack and see if it’s listed on the same page than the screenshot. If it’s not, re-install Slack.

Thanks @Anonyme. I tried dialing this code from the work profile, but it had no effect. It seems like the issue is documented here. It’s probably not worth it for me to do the workaround—I may just put Slack in my main profile.