SLL certificate of mailserver invalid

Good morning,

I just wanted to inform you that the SLL certificate of the mail server has expired yesterday.
My phone+thunderbird app complained about it.

Please renew it as soon as possible. email is a bit important :stuck_out_tongue:

Thanks & have a nice day

Scytale

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I’m getting on Thunderbird the message:


You’re about to override how Thunderbird identifies this site.
Legitimate banks, stores, and other public sites will not ask you to do this.
Location: mail.ecloud.global:993
Outdated information
The certificate is not currently valid. It may be stolen or lost, and could be used by someone to impersonate this site

I have selected “Permanently store this exception”, and I can push on “Confirm Security Exception”, but it does nothing, next time you try to get messages, it’ll pop up again. “Get Certificate” doesn’t find neither download anything, it just responds: “No information available: Unable to obtain status of this site”. And “view” shows me that the certificate should be used not before August 30, but not after November 28. It’s not November 28 where I live (gmt-06) but I bet there are other places where it’s already November 28.

Have the cert expired, how to get the new ones?

I got the same issue on K9, but K9 at least allowed me to set the exception with no issue, I could reconfigure the fetching and sending servers on K9. Thunderbird is not allowing me to do the same. It’ just plainly not allowing to fetch emails, neither temporally store them while being written, neither send them…

I have no clue other than wonder if it’s about the certificates not been renewed on mail.ecloud.global. Again, when I try “Get Certificate” nothing gets downloaded.

BTW, I have no intention to delete my account to then try to login again, that takes way too much, and I of course would lose all configs. So other workarounds, if any, are welcome. Is it really a certificate issue on mail.ecloud.global?

I just got the same, sorry I didn’t notice your post first. This is my just created post:

https://community.e.foundation/t/are-mail-ecloud-global-recieve-send-messages-certificates-expiring/53717

I was looking for confirmation from /e/ + murena admins, but finding your post confirms what I suspected, that it really is about certificates expiring. This hadn’t happened before that I remember, but it’s actually really bad. I just remember all the bad reputation Manjaro got when letting their certs expire the first time, and even worse the second time, :frowning:

+1

I have the same here…

BTW, at this point I’m getting “Unable to connect to your IMAP server…”. So not just complaining about the cert, but actually not connecting. Unsure if it’s due to taking them down to load them with up to date certs, or if things are just getting worse…

BTW, at this point I’m getting “Unable to connect to your IMAP server…”. So not just complaining about the cert, but actually not connecting. Unsure if it’s due to taking them down to load them with up to date certs, or if things are just getting worse…

Same here. I woke up this morning to a notification on my /e/os 1.17 avicii that the cert is expired. So I am glad it’s not my own problem but more of a global incident.

Pl check the announcement here

1 Like

My mail still doesnt reconnect to the invoice server with unchanged server setting, is there anything i can do?