SMS apps don't work under Shelter [CLOSED - unrelated to /e/]

Hey there,

In 2 words, all SMS functionality (launching apps, sending, receiving, triggering) seems to be broken in Shelter.

My system

/e/OS version: 1.6
Phone: FP4

I have installed Shelter as a test to see if I feel comfortable having any shady apps on my main phone (banking, non-Signal messenger apps, dating, etc.).

I have cloned or installed the following apps on my Work profile:

  • automatically added by Shelter:
    • Advanced Privacy (automatically cloned)
    • Contacts (automatically cloned)
    • Files (automatically cloned)
    • microG Services Core (automatically cloned)
  • Added by me
    • App Lounge
    • F-Droid (cloned from main profile)
    • Phone (/e/ app cloned from main profile to test basic phone functionality)
    • Message (/e/ app cloned from main profile to test default SMS functionality)
    • QKSMS (installed through F-Droid to test non-/e/ SMS apps)
    • Simple SMS Messenger (cloned from main profile to test non-/e/ SMS apps)
    • Hinge (installed from App Lounge to test verification SMS functionality)


My issue is that no SMS functionality is available in Work profile:

  • When I launch the Message /e/ app, I have a prompt to make it my default SMS app, the Change button is blue (active), but not clickable (Screenshot 1)

  • When I compose an SMS in the Message /e/ app, the Send button is blue (active), but not clickable (Screenshot 2)

  • When I exit the composing view, I can select the Draft, the Delete button is active but not clickable (Screenshot 3)

  • This is the same for QKSMS (which Message is based on)

  • The Simple SMS Messenger can be installed, but launching it triggers An unknown error occurred and the app appears as a black screen (Screenshots 4, 5)

  • I cannot set a default SMS app, and no SMS apps seem to be visible to my Work profile (Screenshot 6)

  • I can use the Phone app to call from my Work profile in a way that is isolated from my main Phone app, but trying to Send a message to a contact that I have called just opens the main profile’s default SMS app

  • I have tried starting an app that requires a verification SMS (Hinge here), but it triggers some weird white screen with 3 bars on top of the app + a notification that microG Services Core is running on top of my apps + an error on the app when I click outside of that white screen. All the settings in Self-Check for microG are ticked. (Screenshots 7, 8, 9)


Posting as a single image to evade the quota on new users.

What I have tried

  • I have ensured that I was giving all relevant permissions (phone, SMS, contacts) to the 3 SMS apps I am testing
  • I have tried running with/without VPN: same issue
  • I have tried re-installing each app, testing each app in isolation (nothing else installed), re-creating Work profiles, and re-installing Shelter multiple times: this has only allowed me to pinpoint the issue to SMS functionality within Shelter
  • I have looked through the issues on Shelter’s and Simple SMS Messenger’s repos: nothing relevant
  • I have tried running adb logcat -s AndroidRuntime to observe the Simple SMS Messenger crash: it’s not being picked up by adb at all
  • I have looked for related issues in this forum: nothing
  • I have looked for related issues online: nothing

Based on my research, people don’t seem to have an issue sending messages from Shelter in general. They don’t seem to have issues doing that on /e/ either, but my assumption (that comes from a place of powerlessness after hours of testing) is that the cause is closer to the level of /e/ than to the level of Shelter.

Thanks for any help :).

I’ve searched a bit more (as always, searching for solutions works better after posting a support request).

The SMS apps and verification SMS issues seem to be separate:

  • this indicates that there can be no isolated SMS functionality in the work profile
  • this seems to pinpoint the verification SMS triggering issue to Google Cloud Messaging (through microG).

I re-started SafetyNet in microG and the overlay no longer happens, the app simply throws the “We’re having issues on our end” error (which might be rate-limiting after the many attempts trying to get that verification SMS). I’ll know tomorrow if it was indeed some kind of microG issue or if it’s still unclear.

to clarify on sms/calls in a work profile, this and this have quotes:

Work profiles are implemented as secondary users

By default, only the system user has full access to phone calls and texts. The secondary user may receive inbound calls but cannot send or receive texts. An admin user must enable these functions for others.

so on receiving the sms of Hinge inside a work profile… there are multiple ways to send verification codes in Android - not just by plain SMS (that you could allow as admin) but with Googles firebase messaging. Some APIs for verification codes aren’t implemented in microG.

There exist an Hinge issue at microg, but that logcat doesn’t look as it was created with the verification step in Work Profiles in mind -

If you can interact with Hinge while you look at “adb logcat” you might see what’s failing and either add to that issue or create a new one if it really is with microg and not the work profile

1 Like

Thanks @tcecyk, this is very helpful.

I’ll follow your advice and see what info I can add to the existing issue.

I’ll close this specific topic, as the issue is not /e/-specific.