SMS/MMS app question

The device I am trying out /e/ on does not have phone service, it relies on WiFi only.

My plan was to install a messaging app that I have installed on my other “production” devices, it is called “Pulse SMS”, found here: . With this app you select one device as the “main” device, and then all other devices can be “linked” to it, so that you can send and recieve text messages on all the devices. (Works on the web as well.) My intent was to install Pulse SMS and link my /e/ device to my main Pulse SMS device, and then use Pulse on the /e/ device to also send/receive all messages.

I downloaded Pulse SMS from Yalp, and installed it, but I could not configure it. I contacted the Pulse SMS maintainer, he explained that Pulse SMS absolutely depends on what he called “Google Services” being installed on each device. I am assuming that is not part of /e/, and therefore Pulse SMS will not work on /e/.

Here is my question: Is there an alternative to Pulse SMS that will work on /e/? That is, an app that will coordinate messaging with my other devices?

Since my /e/ device does not have phone service, I can’t use something like Signal, since I believe Signal requires me to supply a working phone number on the device. Also - I do not want to have to manage independent message conversations on the /e/ device versus all my other devices.

Thanks in advance.

@dln949 I just tried to install Pulse SMS on my MiA1 with /e/ ROM and it works perfectly. I downloaded it from yalp. There was no configuring required as such it just asked me if i wanted to change my default sms app -which was Signal. I selected yes. I was able to send and receive a sms message. As /e/ has microG it does not require Google Play services. May be the phone service part is important. Will check this with the development team lead .
Adding @rhunault to the conversation to guide

Have you tried silence from f-droid ? It works perfect my device

As @Manoj said, we include in /e/ microG, which is a component that replace Google Services. So it should not have issue with PulseSMS.
That said, I installed it on a device to test. I successfully received SMS on it. As I don’t have any account, I can’t go further than subscription page and test the main feature of the app. @dnl949 Could you please provide me some logs when you are using the app and receiving a new SMS?

Thanks to all for the responses.

Yes, I believe that Pulse will “work” on /e/ when the /e/ device is the only device in question, or when you intend the /e/ device to act as the main device. However, it fails in my case because I need to install Pulse on my /e/ device as a subordinate device. The Pulse installation on my /e/ device should allow me to link it to a main device. Instead, Pulse will only allow me to treat the /e/ device as the main device. This problem is what the Pulse maintainer told me is due to /e/ not having Google Services.

“Have you tried silence from f-droid ? It works perfect my device”

Hmmmmmm… I am not understanding your suggestion, how that would work for me.

As I wrote in my original post, my /e/ phone does not have a working phone number. When I install Silence, I don’t understand… What would I tell you how to reach me if you wanted to send me a text message? Plus, when I try to send a message using Silence, I get this message: “No SIM card found” - which is what I expected to see. Sooooo… What am I missing, am I doing something wrong when I install Silence? What were your thoughts about Silence that you thought it would work in my case? I want to make sure I’m not missing some option or whatever.

I don’t think it is, I have Pulse successfully working on a LineageOS device (which also has Open GAPPS) acting as a Pulse secondary device, and that device has only WiFi capabilities.

@dln949 just wanted to understand the whole scenario.
You have two phones. One of which you do not use to make phone calls. Also this second phone does not have a sim card. This second phone is connected over wifi and you use it via Pulse to send sms messages over wifi. This second phone has lineage OS + Open GAPPS.
You tried to flash /e/ on this second phone and pulse does not work.
While using lineageos + Open GAPPS pulse is able to send sms messages.
Is this correct? Please correct me if my understanding is wrong.

Not quite.

Device 1 has Android as delivered by Samsung, no modifications. I arbitrarily chose Device 1 to be the “main” or “master” Pulse device. Device 1’s phone number is the number “registered” with Pulse.

Device 2 has LineageOS + Open GAPPS. It has only WiFi access. I have Pulse on it. Device 2 is a “slave” device linked in the Pulse setup to Device 1 as its “master”.

Devices 3 and 4 are setup identically to Device 2, and Pulse works on them fine as a “slave” device to the “master” Device 1.

Device 5 has /e/ on it. I would like to install Pulse on it and have it be a Pulse “slave” to Device 1, just as Devices 2 - 4 are. However, when I set up Pulse on Device 3, the setup process in Pulse behaves as if I am setting up Device 5 as a “master” unit - It doesn’t give me the option to set it up as a “slave” to Device 1. According to what the maintainer told me in a brief email to me, he designed Pulse to work with Google Services, and if microG (or whatever) doesn’t do what Google Services does for Pulse, then he said Pulse will not work properly.

Are you thinking that perhaps it is a problem with Pulse, and/or microG?

Pulse with MicroG works on a standalone phone as we tested from our side. It is in this scenario where the /e/ device is acting as a slave to another phone which has the Pulse set up as Master where it fails. Could you raise it as an issue on Gitlab with logs as requested by @rhunault

Of course, I will gladly do that. However…

I am a non-technical person, so, sadly, I do not know how to find the logs you want me to send.

Can you point me to some instructions regarding logs that I can follow?

@dln949 you can get the logs from a PC which has adb configured. Connect it to the phone on which you are facing issues. Run the below command when you use / configure Pulse
adb logcat -d > logcat.txt
this will generate a file called logcat.txt in your current folder on the PC.
Attach the log to the issue report.

Oh, oh…

I have tried many, many times over the past few days to install Pulse on my /e/ device as a slave unit, it never worked. So, as you described to me, I plugged my /e/ phone into my computer, ran the ADB command, and then attempted once again to configure Pulse. And…

Now Pulse appears to work perfectly. For the first time ever.

I do not know what is different this time.

@dln949 oh, sorry, I think I have “over read” something. Silence is a “normal” SMS app like the standard one or Signal, so it needs a SIM card. Sorry for confusing.