SMS -> New message for a new contact impossible

Hello /e/OS community,

Since the Signal application does not allow to send SMS anymore, I use the native application to send messages.

The old sent messages have been synchronized in the application and allow to continue the exchanges started without any problem.

But it’s impossible for me to send new messages to a new contact: indeed when I select a contact in the list, the application automatically sends me back to the list of contacts (This turns into a loop)
I 've clear cache and data of the message application but it did not change anything.

Can someone help me?
Thanks :slight_smile:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Using the default SMS app if I start a “new” SMS using the + in lower right corner … I am presented with a contacts list … I can enter a phone number … it might be an existing contact, or I might enter a “new number” … now I can compose or send an SMS.

Thanks for your answer but it’s exactly what i’am doing. But after typing a number and selecting it, nothing happens => It returns on the list of contact … :frowning:

I cannot explain why the app is not working for you … this is the “compose” view that I see after I select the number.

Out of curiosity, why do you say Signal can not send SMS anymore? It seems I can still select it as the default SMS app…

I wonder if one or more messages although apparently saved are in fact in some way “impossible” and are compromising Message ?

To test this you might create a backup with Backup&Restore. Does this succeed ?

Now you could consider Delete data from Message app. Does Message work now ? Can the backup now be restored ?

Edit. In my experience backups from QKSMS and Message are interchangeable. If following this route, I might also install QKSMS and be prepared to run it alongside Messages. This way backups would be tested with minimum risk of loss of data.

Signal >> Blog >> Removing SMS support from Signal Android (soon)

1 Like

Thanks @aibd for your help.

Unfortunately, I have tried to delete everything, empty the data, start from a clean application but I still have the same behavior. Impossible to get “the compose” view when selecting a contact.

I also tried to install QKSMS but I have exactly the same behavior :frowning:

Thanks anyway.