Solution for paid app developer


I’m migrating from iPhone, and searching a way to get paid app Peak Finder on my future /e/ fairphone.
I contacted the developer who answered the following:

For the moment I do not see a simple way to run a paid app like PeakFinder on e/OS.

If you know a good solution from another paid app, I’m very interested.

Does someone know a way to deal with paid apps without PlayStore or have an example of a solution?


1 Like

Threema It uses a license key.

1 Like

I am in the same boat, I also have just migrated. I am very happy to pay for good apps that respect my privacy. Developers need to eat too.

I look forward to a safe way to buy paid for apps outside of the play store.


@GaelDuval any plans at /e/ to provide a way for developers to sell apps on /e/ app store?

Paid apps subject is all over the forums. Once again I must suggest use of the search function. Tips, tricks, and solutions can be found.

Purchasing the app is one hurdle, whether it works on a GApps-free ROM is something else. I don’t see a free or trial version of PeakFinder for testing. You may wind up paying $5 for an app that might not run.

PeakFinder testing. I know that PeakFinder uses some Google services but to what extent I do not know. I am in the process of testing it in three different environments. Just installing though is taking forever as midday/primetime data speeds are slow. I’ll continue after work.

One good note, the app has no trackers.

Stay tuned.

FairEmail and iCal Import/Export are more examples of paid apps you can get for custom ROMs without Google pay framework.
So the developer of PeakFinder can contact the developers of these apps to get more information.

Despite searching before creating the topic, I didn’t find what I was looking for :slightly_frowning_face: it’s not easy to find the correct keywords for the search results to be precise…

Thanks a lot :smiley:

I’ll email this topic to the developer :+1:

1 Like

Ah, that’s true sometimes. I guess, briefly, the options will depend on if the developer is willing to accommodate those who don’t want to use the Play Store or have a Google account.

If one has a Google account then the app can be purchased via the web version of Play Store. Then install with Aurora Store using that account.
The Google account is only used within Aurora Store, not systemwide.

Hopefully the dev can consider or be open to other means of payment. Some offer license files (Titanium Backup), PayPal transaction IDs (GravityBox), and other means like @ff2u mentioned. I’m kind of missing XDA Labs sometimes.

My testing of PeakFinder was pretty cool. I’ve never heard of the app before. Nice seeing all the names of the mountain peaks in my area. I knew a few and see I know a lot less. Haven’t tried it in the daytime with the camera yet.

Up front, PeakFinder is one of those paid/pro apps not unlike those that have been part of my Android toolkit for years. Root Explorer, QuickEdit, SMS Backup & Restore Pro to name a few. Full versions that work anywhere, no license checking, no Play Store checks, no reliance on Google’s framework (GSF) - at least nothing that impedes functionality.
Some other apps and launchers have a separate pro key that also works in Google-free setups.

Decided to buy PeakFinder just for this test. Wound up testing in five environments on four devices.

Tesla Nougat, microG, patched Play Store from NanoDroid (Moto G5 Plus potter), my daily driver.
/e/OS Pie, microG (Essential PH-1 mata).
/e/OS Nougat, microG (ZTE Axon 7).
XenonHD Oreo, UnifiedNlp [no GApps, no microG] (MotoG5s Plus sanders).
Candy7 Nougat, UnifiedNLP (ZTE Axon 7).
[ I multiboot on the Motos and Axon ]

Once app was installed and data downloaded (some difficulties, WiFi vs mobile, Motos with limited or no compass, slow connections) PeakFinder worked in all environments.
With the two non-microG ROMs (UnifiedNlp) there is a toast at startup that says…
Application license not found
…but it has no affect on the apps functionality.

Since my ROMs are rooted I use Aurora Store’s root installation method (causes apps to think they are installed from the Play Store utilizing FakeStore, included in /e/OS). So, for completeness sake I uninstalled PeakFinder, changed Aurora’s installation method to Session (Native Installer method apparently doesn’t work with split apks) and reinstalled. PeakFinder still ran fine.

So it seems that PeakFinder is definitely microG friendly. As mentioned earlier, also no trackers according to App Manager.

1 Like

Thanks a lot @marcdw for all this tests and feedback!

So if I understand well for now, I need to get the app on PlayStore online, then get it on my future /e/ Fairphone using Aurora Store (I don’t now this app) and that’s all? Or do I need MicroG as well?

Well, you don’t need microG but since it’s included in /e/ that’s not an issue.

Aurora Store is an app that allows you to install apps from the Play Store. No Google account needed for free apps.
If an app that you want isn’t available from /e/ Apps store or F-Droid, the Play Store probably has it. Aurora Store would be the way to get it.

For Google users who have bought some apps in the past, in most cases you can install them using Aurora Store. You can login to Google inside the app and install paid apps.
Not all paid apps will work. If the apps do license checking at startup they will fail because the Play Store isn’t installed to handle the checks. Apps that have In-App Purchase also won’t work.
In the case.of PeakFinder you should be good.

Aurora Store is available from the /e/ Apps store. It is from Rahul Kumar Patel. Currently at version 4.0.7. I mention the author because I just noticed a bunch of Aurora Store related apps on /e/ Apps I’ve never seen before (probably because I don’t use /e/ Apps). Stay away from those. They look, fishy.

The following could probably be in its own thread. Some of you may have noticed or not but Aurora Store 4.0.7 remains in memory for some strange reason. You can exit and swipe it from Recents/Overview but it stays in the background. It keaves a permanent notification that can’t be swiped away. Someone opened an issue on their GitLab about that. At last check there was no responses. One has to force close the app.
Have no idea why this was implemented.

I personally noticed that this also keeps sessions open that eventually expire. When I first came across that I thought something was broken and I would have to logout and login again. But killing (force closing) and restarting was good enough. I have no idea why this remain-in-background “feature” was implemented.

1 Like